Ardour and XR18 mixer

Hi everyone,

I am using Ardour6 on Ubuntu Studio. I coonected my laptop to a Behringer XR18 digital mixer.

I managed to record instruments connected to the inputs of the mixer.
However, I can’t find a way to configure Ardour (or the mixer) so that Ardour can play the recordings back…
Does anyone here uses a similar setup ?! Ardour + XR18 ?

How do I configure the Ardour so that it plays the recordings on the PA/Monitors I am using in my rehearsal room ?!

Any help much appreciated !!!
Best,
Vincent

I have a setup with the Behringer XR18 and it works well.

With my set up I am running in multichannel mode (so 18in, 18 out on the USB) and I have dedicated channels 17 and 18 for the playback. I also use 17 & 18 as a master mix back to the PC so I can choose whether to record individual channels or to record a mix.

in my case I am not using the master channel physical output on the XR18 as my monitors are connected to two of the bus outputs, which I then link into a stereo monitor output.

Obviously, from the Ardour point of view, I need to connect the master bus out (and any other stuff I want to hear, like the metronome, auditioners, etc.) to channels 17 and 18.

I don’t have my XR18 setup to hand currently, but I recall that I have configured channels 17/18 as USB inputs (you have a choice on each channel as to whether the channel comes from the physical input on the XR18 or the USB input from the PC) and configured the output busses to my monitors so that channels 17/18 are connected and have the level turned up.

I will point out that the XR18 is a clever, but complex, bit of kit. If you aren’t getting any audio, it’s probably to do with how you have configured routing and faders on the XR18 itself. It’s very easy to get this wrong and end up with no audio.

If I can get a remote login to my home PC, I’ll try to pull down one of my saved configurations.

Cheers,

Keith

Thank you very much Keith, I will look again at the config of my channels

Some more on my XR18 setup via remote access with screen shots from Behringer X Air Edit on Linux.

As I said, I’m not using the main LR outputs for my monitor speakers. Instead they are connected to two busses connected as a stereo bus. I am using Busses 5 & 6:

These are mapped to the Aux input channel on the mixer, as seen in USB Returns:

The Aux channel is configured to USB, with the level up as seen from the monitor busses 5 & 6:

To be clear, you have different mixing views, one for each output (either “main LR” or a specific bus). To see the mix settings for a given output you need to click the appropriate output on the GUI. In this case I have Bus 5 clicked which is stereo paired to Bus 6 for my monitors. I have named these “SPKR L” and “SPKR R”.

If you are using a bus output instead of “Main LR” and haven’t clicked the bus and set the levels, then they will default to the minimum fader level and you won’t hear anything.

I am also using busses 1 & 2 as a mixing bus to send to channels 17 & 18 on the PC, which can be seen on the routing for the USB Sends:

Of course, each individual input on the mixer is connected to the associated USB channel, so I can record them individually by selecting channels 1-16, or I can record the mix by selecting channels 17/18.

I hope this helps.

I have also put a copy of the Scene file I use here.

Cheers,

Keith

Thanks a lot Keith, it sure does help, I need to process this first !
I will let you know if this solves my problem.