Ardour and PipeWire playback only..?


I am testing PipeWire 0.3.79, wireplumber and qpwgraph and the first thing I’m trying to determine is how to just start Ardour and use it for playback… Before if I just wanted to Edit and Mix without recording I would run Ardour with it’s PulseAudio backend and that worked exactly as I expected… So now unsurprisingly if the PulseAudio backend is selected Ardour hangs for a significant amount of time and then blurts an error about PulseAudio and kicks me back to the Audio/MIDI setup dialog and this leaves me with the choices of ALSA or JACK… If ALSA is chosen Ardour as expected takes control of the Audio hardware… fair enough but in my experience when Ardour is shut down PipeWire does not uhm…errr… ‘respawn’ and the system is left with no Audio… annoying! Selecting the (actual) JACK backend does the same thing… PipeWire and qpwgraph are completely unaware that JACK is running… Further to that if I’m going to commit to PipeWire I want to use Pipewire’s JACK facilities and not 2 different JACK servers.

So does this mean with a normal Desktop session running with PipeWire I can’t just simply start Ardour and have it work in some playback mode that allows usual Desktop Audio flow and doesn’t either require punching PipeWire in the nose and stealing it’s hardware OR having JACK/jackd/jackd2/jackdbus still installed on the system unless I:

(a) make a special launcher for pipewire-alsa to give me 8000 Audio ports I don’t need OR (b) Invoke some special pipewire-jack LATENCY and SAMPLERATE command in a terminal just to run Ardour…?

Is this really what using PipeWire and a DAW is about?? PLEASE correct me if I’m wrong here…

A few years ago, I spent a few hours trying to get pipewire to work with Ardour / Jack / Pulseaudio. There were supposed good benefits to it. It was not fun. Too many problems to list. I uninstalled pipewire, and for some reason, gnome-desktop gets uninstalled as well (Ubuntu 20 something).

I will only try pipewire on a live cd next time. If I cant get it to work in 10 mins, then Idont want to use it.

Sorry I have no useful information to help. Just a similar situation…

1 Like

Casting my vote for a 2-year moratorium on Pipewire in AVLinux :slight_smile:


Hah! Well my gut feeling is that may be exactly what will happen, but I would be remiss to not fully give it a try and see for myself what it’s about before arriving at that conclusion…

I do not have that problem on Fedora, so I think something may not be quite right in the Pipewire configuration.
Same with jackd, there is an occasional problem where jackd gives up before pipewire has finished reorganizing itself to hand over the audio interface, but if that happens jackd will start on the second attempt, and the transition back to pipewire after stopping jackd works OK.

It does seem really inconvenient right now to get pipewire to shift between optimal desktop and optimal production settings. I have not looked at the pipewire API to see how difficult it would be to do programmatically. Anyone ever see if Rui commented about adding something like that to qpwgraph? Make qpwgraph a little closer to qjackctl in features related to picking your starting settings.

[edit:] Looks like someone else had the same idea, but Rui said not going to add to qpwg:
request to add settings control to QPWGraph issue 79

1 Like

I just did a quick test.

I started pipewire along with pipewire-pulse:

$> systemctl --user start pipewire{.socket,.service} pipewire-pulse{.socket,.service}

I started Ardour, created a new session, chose “Pulseaudio” from Ardour’s Audio/MIDI setup dialog. I added a midi track, tested the sound, everything worked.

I am using the same version of pipewire that you are. I use Arch Linux. I did not have to perform any customization of pipewire. wireplumber is configured to start with each system boot ( via systemd ).

As an aside, I use jack (not pipewire-jack) when working on music production ( E.G. Ardour ). However, it was an interesting test.

Hope that helps.


When using pipewire, there should be no need to use Ardour’s Pulseaudio backend at all.

Ardour’s Pulseaudio audio-system is (was) mainly a stopgap solution for situations where one needs playback to bluetooth speakers (ALSA or jackd using ALSA do not support this), or casual listening sessions alongside Desktop Audio.

Since pipewire already bridges this, pw-jack Ardour7 and using Ardour’s JACK backend is the way to go.

That being said, properly setting up pipewire for pro-audio is still far more complicated than it should be :frowning:


Thanks all for the replies, despite my sarcastic tone (it’s in my DNA) I actually am legitimately looking for some answers. :slightly_smiling_face:

So it appears my basic PW setup is missing some functionality to restart once the Audio device is freed by either ALSA or JACK… Another potential hurdle is that my base is MX Linux which uniquely can boot as either systemd or sysvinit so perhaps their PW installation defaults are influenced by that…

It is interesting that forcing PW-PA at system start will enable Ardour’s PA backend to work, but that seems to be non-standard start command and I wonder if there would be unseen complications with other programs with PW-PA running all the time…?

Soooo in the end you essentially cannot run a default install of Ardour (or Mixbus, or Reaper, or Bitwig or Qtractor…?) from your menu without either jigging how PW starts on the system or modifying launch commands. I’m sorry but that seems batshit crazy to me… And for so many years people thought JACK was too confusing and difficult?

1 Like

I have an Ubuntu 18.04 PC where I’ve compiled and installed PipeWire
When I start it and then start Ardour it works just fine; I can play a session and run YouTube in a browser at the same time. No magic tricks needed.

If you want to run PW you should make sure your system is set up to launch a full fledged PW on boot.
What I’m seeing in some distros now is that they use PulseAudio as the main sound system while also running parts of PW for conference programs (I believe).
If that setup isn’t great for running Ardour that’s not PW’s fault.

1 Like

For me Pipewire never worked well. Latest tes few month ago. I’m ok with Jack+Pulse.



This is not the case here, PulseAudio has been removed from the system, however I do stand corrected in that Ardour WILL use pipewire’s jack implementation automatically when the Audio/MIDI Setup’s JACK backend is selected without the special ‘pw-jack’ prepended command so that is promising…

Pipewire with the pipewire-jack module loaded should just look like a jackd server to audio software. You only need pw-jack if you have both pipewire-jack and jackd on your system, and you want to make sure the pipewire libraries are loaded and not the jackd libraries.
From the man page:
" If PipeWire’s reimplementation of the JACK client libraries has been installed as a system-wide replacement for JACK’s own libraries, then the whole system already behaves in that way, in which case pw-jack has no practical effect."

Having both jackd and pipewire-jack installed is not recommended. I don’t know how the packages are setup in Mint (and whether there is just one set of packages for Debian and derivatives, or if the derivatives like Ubuntu and Mint have packaging specific changes), but in Fedora the packages cause the package manager to treat pipewire-jack and jackd as exclusive replacements for each other, you can only have one installed at a time unless you go out of your way to force override of the warnings. In that case (of package manager forcing exclusivity) either you don’t need pw-jack because pipewire-jack is the only implementation installed, or pw-jack isn’t even installed because jackd is the only server implementation installed.

Have been using pipewire for almost 2 years on Gentoo. A couple of minor bumps in the road early on, but has worked without issue over the past year. Most problems people run into tend to do with how their distro configures it rather than pipewire itself.

The last bit of functionality yet to be implemented that is important to people here is utilizing the ALSA driver IRQs, which makes low latency much more stable. After that the 1.0 version will be released and I doubt there will be any significant reasons not to use it with Ardour at that point.

1 Like

In the normal pipewire with pipewire-jack package installation you don’t need to run pw-jack command before running Ardour or any other app that uses Jack. Pipewire has it’s own version of jack libraries and simulate Jack server running all the time in background. Ardour sees Jack Server running even without this “pw-jack” command.

Hi Glenn, I testify I have no more Pipewire-Ardour problems since I’m using Ardour in ALSA-Pipewire mode, it solved all those problem for me in any distro, this is how I made it in one of my earlier posts:

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.