Ardour and LADSPA Trigger Plug in

i’ve installed the deb file from the official page but i cant find it on Ardour’s plug in manager , someone can help? im using ubuntu studio 12.10

I think, but am not totally certain, that you folks have a misunderstanding of what the LADSPA trigger plugin does. But then again, I have no idea what it does, so …

@miguel325: so the problem seems to be worked out.
As Dr. Zoidberg would have put it: Hooray! Another plugin that is loaded perfectly correct by Ardour even though it is, in itself, dysfunctional!

@zettberlin Yes, my system is 64bit, that is the problem then i’ll try to build it myself(if i can LOL) , i wonder if there is another plugin for the same purpose,
thank you very much for taking your time to help , please let me know if you find a solution for the sound, cheers.

@zettberlin I managed to build the plugin from source(i’m not very experienced doing things like that) and now Ardour lets me select the plugin from the manager but makes no effect on my drum track(seems like the plugin doesn’t get signal to trigger the sounds) as expected from your answer , its a shame i dont know about programming to solve it , maybe on 32bit will work.



@miguel325 If the file is in this folder, then the deb-package worked OK and the plugin is where it supposed to be.

I have tried it myself and see, that Ardour does not load, throwing a message regarding a invalid ELF class, that means, that the deb-package from Sourceforge is for 32bit only while my system is 64bit.

Could this be the case in your installation too?

Anyway I have downloaded and build the tar-gz archives from the files section of triggers sourceforge site and Ardour shows and accepts the plugin OK so it may be an issue with the 32/64bit formats.
BTW: the plugin looks like working still I fail to make it play any sounds…

If the deb does not install to a proper folder, then the deb is awfully broken. Anyway: you can just copy the lib from the place, deb has put it to one of:


I would try the dot-folder in home, so you dont need to play around as root.

so i just need to copy the installed files and paste them where they are supposed to be?

@zettberlin Checked the places you told me and there is only a “” file at /usr/lib/ladspa where all the other plug ins are , what si the next step?

@cajmere I got A3 it from this site, @seablade yes i think that is the answer, is there a way to install the deb to the LADSPA_PATH?

The real question is going to be, where did the actual plugin get installed to by the deb. If this is not a ‘standard’ path and not a location pointed to in LADSPA_PATH Ardour will not find it.


from where did you get ardour?
Did you build it your own or was it taken from the ubuntu repository, or something else?

Given the parameters in the GUI and the data in its package (samples as wav-files included) I think it should spit out these wave-samples if the audio in a region in a track reaches a threshold that can be tweaked in the GUI. MDA has such a beast called beatbox, as I try it in Ardour3 I get the impression, that there could be something wrong with Ardour as a host for such Plugins. The MDA-Beatbox does try to play samples when triggered but as soon as it spits out anyting, the meter in the track peaks up to 700db and I hear extremely distorted noise.
In Qtractor Trigger works as expected BTW.

Could there be something wrong with the samples?