ardour and jack needs sudo

Hi. I can’t run jack as realtime without using sudo. How can I change permissions for doing so? Currently I’ve been doing sudo jack, then sudo ardour to get it working in realtime latencies, but it’s kind of a problem, because I have to run all programs as sudo to connect to jack. I know it shouldn’t be like that. On my old system, I’ve aplied many tweaks for audio work, and I didn’t have this problem. But now I can’t find those pages with the tweaks needed for running a linux proaudio system. Any links maybe?

BTW, using Hardy here.


Hi, i Had almost the same problem with UbuStu 8.04

The problem is (in my case) in the /dev/raw1934 device, where your user has no write (and maybe read too) permissions

The fast way:
try “sudo chmod 777 /dev/raw1934”

If this device does not exists, try
“sudo modprobe raw1934”

and then the previous command again.

The right way:

Now I’m not in front of my Laptop, the right way should be something like:

Add your user to a group who has r/w permissions over that device, try again :slight_smile:

Hope this can help, sorry for providing only the “fast way”, i usually use only that one :smiley:

Sorry, slow connection, clicked twice :slight_smile:

You shouldn’t have to resort to chmod/sudo hacks to run things realtime.
Make sure you have something like
@audio - rtprio 90
@audio - nice -10
@audio - memlock 256000

in your /etc/security/limits.conf, add your user to the audio group, reboot and try again.
This is the right way to do it.

You might have to install a -rt kernel but the standard kernel should do (by judging from the other distros I use).

thanks for the help. I’m not sure, but it seems my ubuntu Hardy comes WITHOUT a group called “audio”. At least that’s what “Users Settings” manager says. it doesn’t list any audio group.

So, should I create the audio group first than add my user into it. And if so, how can I set disk privileges for this?

even more strange… Although audio is not listed in the groups in the “user and groups”, when I try adduser “myname” audio, it says “myname” is already a member of audio group… So, does audio group in fact exists, but isn’t listed there for any reason? How do I change privileges for “audio” group. It’s still a little confusing for me, sorry…

—@ mari8i—
Tried it but it says there is no module called raw1934… Do you mean raw1394 instead maybe? Also isn’t it just related to the firewire port? I’m not using firewire wth ffado or freebob. i’m using RME PCI audio card, and it works great, by the way. Just checking, because sudo modprobe 1934 won’t work at all. ???

ok, it seems simply adding those lines to my limits.conf does the trick for running Jack in realtime as user… BUT…

Now that i can run ardour as user, it says it can’t create the session folder at home/user because permission is denied… Any help on that? Why is Hardy so Hard on permissions? Or is it a problem everyone has to go through in order to run ardour?

That’s probably because you’ve already created the
directories as root while you were messing about with
su privileges, so the files are owned by root and not you.

Now you can run as yourself, all you need to do is
cd to your home directory and run

sudo chown -R *

(put your own login name rather than “user”, of course)
to set the ownership (it’s ownership, not permissions
that are the problem) of all files and directories
in your home directory back to yourself.

To answer your other question, all unices are very tight with
permissions and ownership because it’s a multi-user system -
if you have ten people logged in on one machine, you don’t want
them messing with each others’ files either by accident or

You’ll thank it one day, believe me.


I’m now running VST on linux. HAHAHA. F#$&( Windows!

really, thanks for this guys. You are awesome.

Hello, I have a similar problem and I think it is somehow related to jackdmp. Because after installing it I can only use realtime as root. I’m using ubuntu hardy 8.04 with realtime kernel and I’m member of the audio group. My /etc/security/limits.conf has:
@audio -rtprio 99
@audio - nice -19
@audio - memlock unlimited

This is the output of ‘id’:

jorgose@ubuntulaptop:~$ id
uid=1000(jorgose) gid=1000(jorgose) groups=4(adm),20(dialout),24(cdrom),25(floppy),30(dip),44(video),46(plugdev),105(scanner),107(fuse),109(lpadmin),115(admin),124(sambashare),129(audio),1000(jorgose)

I’ve already seen this using a 64bit version of ubuntu hardy. I thought it had to do with mixing 64 and 32 bit libraries, so I reinstalled on 32bits, but it happened again.

Fixed! I just put a blank space between the minus sign and rtprio 99 and rebooted.

I just set up Ardour for the first time and went through this. Perhaps the permissions howto should be in official doc or FAQ or something? $.02


I was having the same issues as the original poster, so I thought I’d give a try to these suggestions. While they allowed me to start using Jack without the need of using sudo, I am getting all kinds of weird issues now. Ardour seems to run OK for the most part, and I don’t see Xruns when recording with it, but Hydrogen started to have major issues.

Basically, whenever I hit play, after a few seconds, sounds start to distort, I hear flanged sounds all over the place, and some of those samples get skipped for no reason. I started to play around with Jack settings, but nothing seems to make any difference.

Does anybody else have this problem? Any ideas on how to solve it?

A flanging sound indicates a signal is being mixed with a slightly delayed instance of itself. Follow Hydrogen’s output in the JACK Connections window. The fact that you say it happens after a few seconds suggests a feedback loop, although within a stricly non-acoustic environment such as your computer this effect should be noticeable rather immediately (unless there is some other delay-based DSP in the chain such as reverb). The waveform could be summing with itself, increasing its gain until clipping occurs.

As for samples being skipped, I’ve experienced that too–probably a bug in Hydrogen.


do you hear this flanged effect when you play hydrogen with ardour sync’ed to it (jack transport mode) ?

If you have ardour set to provide software monitoring, and hydrogen connects to your system outputs as well (hydrogen default), then what you get is twice the hydrogen output, one being slightly delayed because it’s going through ardour. Schematically :

hydrogen_out -> system:playback_1/2
hydrogen_out -> ardour:tracks -> ardour:master -> system:playback

If such is your configuration, either disable ardour’s software monitoring, or disconnect hydrogen from the system:playback.


Thanks for all suggestions, guys. I will look into it.

My only concern is that I am using the exact same Jack routing schema I was using when I was doing sudo, and it had no issues then. On top of that, I would think that a routing feedback would be there every time I hit play. However, it is playing OK at first. Then, as soon as I click stop, usually Jack gives me an Xrun and I start getting this issues on successive times I hit play…

Very weird. I will make sure I get rid of those potential routing issues and see what happens.

Thanks again

oh, you used ardour and hydrogen with sudo ? wouldn’t that imply that you have the $HOME/.ardour2/* files and and $HOME/.hydrogen/* files written by root ?? or does it imply that your former configuration was written in /root/.ardour2 and /root/.hydrogen ?

invoking sudo for jack apps is not a good practice but that’s the only way you found before … I would suggest you checked whether $HOME/.ardour2 and .hydrogen are root-owned …
but maybe it’s a non issue. If you started ardour and hydrogen the 1st first time as yourself, chances are that the ownership is fine.

Hey, Thorgal,

I started Ardour as me long before I started using sudo. The reason I started using sudo is because (not sure why) the other recommendations wouldn´t help in using Jack with RT. After I started using sudo, it worked, but I got tired of all the ownership implications that brought up, so I started looking for a solution, and I ended up here.

Anyways, I will try these suggestions and will check ownership to make sure it´s not the root of the problem.

Thanks again

If anyone is interested, I finally found a way around it by simply creating some files from scratch. I think there were some strange ownership issues that got resolved then, and now it all flows!

Great stuff, thanks all!