Ardour and harvid opening video fails

I’m guessing this is a set up or incompatibility issue.

The system and software:
Ardour 6.9-5
ffmpeg 2:5.0-4
harvid 0.8.3-3
Manjaro 21.2.4
Xjadeo 0.8.10-4

When I attempt to open a video I get this warning in the Ardour log:

Parsing video file info failed. Is the Video Server running? Is the file readable by the Video Server? Does the docroot match? Is it a video file?

If I open the harvid server in a browser window the file I selected is shown and it’s info is accessible. (I’ve not found a way to determine if harvid can respond to play it or how to test if harvid is actually working.)

It appears I need to start harvid from a terminal window. Maybe a clue?

Do I have a mismatch of software?

Your version of ffmpeg is too new and not [yet] supported.

see also Can't import/play videos (anymore) - #2 by x42


I was afraid that was going to be the answer.

Arch/Manjaro strikes again.

I have yet to figure out how to back something like that out of Manjaro…

Oh well.

Chances are that upcoming Ardour 7.x will be compatible with ffmpeg 5.0.
You can meanwhile just use the video tools provided by

Easiest by running the video-tools install script as show in the manual. Or alternately by manually exacting and copying ffprobe_harvid to $HOME/bin or /usr/local/bin.

Hmm…Yesterday I did try the “sh -c “$(curl -s -L”” and it failed, sorry, I forget the error.

After reading your last post I attempted to put ffprobe_harvid into $HOME/bin, but the home bin directory did not exist, so I put it in /usr/local/bin. Ardour got the same errors as before.

So, I ran That worked once I figured out that it wanted /usr/bin as an argument.

Then Ardour seems to find a open the video and display it. But, it doesn’t seem to extract the audio. Not sure if that is a set up issue…

If was a frame rate issue with the sample I was testing with…

Looks like it’s actually work!

Thanks again!!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.