Ardour, a few issues.

Hello to everyone, recently my computer kept switching on and off perpetually and when consulting my London Linux Guru friend Trevor, was confronted with “It sounds like a hardware problem”. After replacing every component one by one, and trough a process of elimination despairingly discovered that the bastard switch on the case had been the culprit. Anyways, c’est la vie! Subsequently a few days after, I installed 64Studio, since I’m a songwriter/musician, it seems to be the ultimate recording system. I usually record on a Roland VS1880 (18 track) HD recorder and limit my computer to final mixes. However after delving into the potential of 64Studio I was considering a permanent shift towards the desktop. In such a setup Ardour would be crucial! I’ve spent the last 36 six hours testing most of the stuff. The installation ran smoothly and everything seemed operational. However when testing Ardour I encountered a few problems. I first created a simple pattern/groove on Hydrogen, quite a remarkably sounding piece of software, and recorded it onto Ardour, managing to synchronically trigger it all from Jack, COOL! I did a little editing copying, pasting, punching in, etc., and was beginning to get very, very excited. Next I recorded a rock rhythm guitar track using three Caps plug ins and the cool sounding Tap Reverberator, great stuff. Next, I decided to do a third track (lead guitar) and at this point it started getting a little shaky. After adding a new plugin, as soon as I touched any parameter I’d get a message saying that either Jack or Ardour were to fast and hence disconnected, since Jack was still running I suspect the problem is with Ardour. I also started getting the close and save session appearing a few times. Also a log window displaying the message Zombified kept making its presence. Furthermore, when reopening and playing the session the DSP usage would swing from anywhere from 10% to 90%, staying at a rather busy 28% if un-interfered with. It seems quite a lot of usage for three simple basic tracks. Also after recording track two and disconnecting the inputs, id have to leave the plugins active in order to hear the track as recorded. This seems illogical, unlike my Roland studio, once you’ve recorded, any input or pre-fader Fx can be removed, thus liberating effects for further use, and as I now discover it might lower processor usage. I must say I’m perplexed as to what the issue might be, everything else on the system runs fine. Did I buy right hardware? :Athlon64 dual core 4200, 1GB DDR2 667 Ram, 250 sata hard-drive and using a Edirol UA-25 interface. In another post I read the suggestion of lowering the frames period, which would effectively increase latency and since I like to use software monitoring when playing e.g. guitars, it might be a little to painful in terms of timing. Does anybody know what might be the problem? Yours thankfully, Andrew

what kernel ?
which patch (low latency ? complete preemption ?) ?
what jack version ?
what ardour version ?
running realtime ?

it’s a great story but you need to provide details about your system :wink:

It may not be anything so esoteric.

It could be that one of the plugins you are using is causing your problems. Try removing them one by one and see if the problem goes away.

Secondly, it could be that you are using a USB soundcard. I use 64Studio and have similar issues using my Tascam US-122. My M-Audio 2496 (PCI card) works perfectly.

You should be able to record, mix, and process several dozen channels with your setup, without any hiccups.


Also, I believe it is standard to leave the plugins on…that’s the beauty of computer based recording, you don’t run into the ‘no more effects’, you are only limited by the power of your computer. That way, if you decide later on that the reverb is too heavy, you can change it easily. I have done fairly large projects in the past (admittedly not with Ardour), around 32 tracks, and all the tracks had some sort of FX, whether it was a compressor, EQ, or verb, etc…it was even with an older computer, with a much slower processor. If you do run into problems with CPU power, I would suggest using a group channel…that way you can send anything that you want verb on to that channel, and save CPU resources. Hope that helps…

Thanks for replying! Actually I did a second test. First a couple of Hydrogen tracks followed by a rhythm guitar. I then did a lead track and added plugins and it all began to become unstable, music being paused continuously during playback. I’ll give the group channel option a try, if I can figure it out. I’m starting to believe my computer is not up to the job and probably I’ll have to do some upgrading of sorts. Hopefully, I can sort it and arduously make an all Linux track in the near future. However I’d like to have certainty as to what part of my hardware is being deficient. Thanks for the help, A.

Thank you! Yeah, I’m starting to follow the same line of thinking. I did some more tracks and problems began when using plugins. I suspect I’m not very qualified at buying computer parts. I’ll definitely consider a pci card. Probably I also need some higher quality ram. Thanks for the help as I must me be the most IT illiterate Linux user. Actually I’m aiming for 24 audio tracks. It would be nice to know what array of components would manage that situation comfortably and compatibly. Thanks Ben, nice one, Andrew.

Hi there, well I can only half answer to that as I’m a complete novice in Linux terminology. I installed 64Studio, a comprehensive musically orientated system, based on Debian, I suppose Debian would be the kernel. Actually, my mate Trevor, quite an authority in all things Linux, provided me with a Cd image. He burnt the Cd a few days ago, so I suspect Jack/Ardour would be in their latest versions. As to which patch, I’ll have to consult my friend. However, I think I made the mistake of installing the lot on a single partition, I ran into utter panic at the partitioning phase of the installation as i was by myself, so probably I’ll need to re-install and drink a double gin and tonic. As to my system:

Athlon64 dual core 4200 (I’ve googled it, and its 2.2 GHz, if that’s of any help)
1GB DDR2 667 Ram (Apparently, I could fit some 800mhz ones, would that improve matters?)
Maxtor 250Gb sata hard-drive (sadly quite a noisy monster for a recording environment)
Edirol UA-25, is where I plug in, and someone has mentioned that usb is not so ideal for a soundcard.
Do you reckon this gear is up to the job, or is it inappropriate? Anyway, thanks for the interest, thanks Thor!

The kernel is actually something smaller than Debian - to find out what kernel you have, go to a terminal and type

echo uname -r

and press enter.

It should then say 2.6.something

That is the kernel version (loosely speaking the version of Linux) you are running.

if you have 64studio, it is debian geared for audio stuff. As tgoose mentioned, uname -r in a shell and you know your kernel version. An alternative is to open the package manager synaptic and search for ‘linux-image’, it is the package that contains the kernel binary. The packages are versioned, so you would know which one right away.

As far as I can tell, your h/w seems fine but again, there could be sneaky things (what is your motherboard by the way?)

Performance apart, if you care about the noise your PC makes, I can suggest you do the following :
get some Western Digital hard-disk (the 500G Caviar SE serie is quite OK). Cool things down with Zalman stuff (passive coolers for HDs, and the big CNPS9700 for the CPU if compatible with your CPU socket). For the PC case, the Antec Sonata III is pretty good). I use some of these gears myself and I am very satisfied. There are more drastic solutions (bombastic liquid coolers, whatnot) but it’s up to you.

COming back to your problem : did you start the jack audio server prior to starting ardour ? or did you let ardour start jack ? if you use an app like qjackctl to start jack, it is useful to look at the jack messages. So what does the jack log contain ? do you have tons of xruns ?

Hi, 've just tried the terminal method and failed, surely 've done something wrong. However the Synaptic Package manager yielded a result: Linux-headers 2.6.21-1-multimedia. I’ve always started Jack first as it seems to be the heart of the audio system. Actually, I think that a couple of times I tried to start Ardour first and it didn’t let me, sending a message that Jack was not started. I have looked at jack’s log window and once it had loads of xruns that referred to time in milliseconds, but couldn’t understand what it meant. As to the motherboard it’s a GeForce6100SM-M2. Next time I’ll copy any Jack messages to a text editor if that’s of any use. Thanks ever so much for the support, A.


my immediate suggestion would be to look if your system’s hard drive configuration is well configured (use hdparm) or if your jack startup config isn’t too ambitious.

The best way to fix your matters is to check out the ardour channel at with an irc client (you may have XChat or something similar pre-installed), just select Freenode and then #ardour.

Or otherwise type
“uname -a”
in a terminal and write this here;
“hdparm /dev/sda” (you need to do this as root or use
“sudo hdparm /dev/sda”
and write it also here;

then look if you have a file called “.jackdrc” in your home directory (it’s hidden). If you have that, post the content here.

Maybe some of this will fail, but any information is good at this point.

As I said, the best way is to enter the IRC Chatroom where you could discuss the matter with someone in realtime.


Sorry for misinformation; I posted before half asleep and not on a Linux machine; as others have said what you should have typed is simply

uname -r (for the kernel version)


uname -a (for more detailed information)

Hi Benjamin, thanks for the information. My system has Ekiga Softphone and Gaim Internet Messenger, I don’t know of any of these are suitable, if not I’ll download something compatible to join the chat room. However, matters have since ameliorated, so I’ll probably focus on other ideas. With no further ado, sincerely yours A.

Not to worry Mate. It was still quite fun to open the root console, I have never done that alone without the supervision of someone who understands, it was a bit like the Matrix Revolution. There’s so much I need to learn! Thanks for helping, A.

Gaim will work for IRC. You have to enter in and when you have a new window, type /j #ardour and you should see a big list on the right of the people present. I use similar hardware to yours with 64studio, and a PCI audio interface would probably be a good next step.

Thanks, I’ll try the IRC channel shortly. As a matter of fact, I’ve just been reading about the system requirements and it mentions that USB interfaces are not good if one wants low latency. Currently, I’m using an Edirol UA-25 (USB). It’s a pity, 'cause it has all sorts of inputs/outputs in a box, which one can position near the monitor. The prospect of having to plug everything at the back of the pc case, although not impossible, seems a little cumbersome. However, performance and audio power is what really counts. What would be the best option PCI audio card, if one had to consider both, performance and price? Thanks for the info, and the advice too, Andrew.

RME Hammerfall HDSP (PCI part) + Multiface II (IO box) if your budget allows. You will not be disappointed! You will need preamps though (like the RME QuadMic, sure thing too).
If fully linux supported, I would even suggest the Fireface 800 … but that’s risky (no linux support unless I am wrong) and extremely pricey …

I had exactly the same problems you describe and it was the plugins that were the problem (on Mandriva 2008). I do not know why, but all I had to do was to remove the plugins using the software management tool and then build them myself from source. That completely solved this problem for me.

I’ve googled this gear and it sure looks stupendous. However, I’ve been looking at a wiki page that lists tested sound cards, and apparently mine is supported. Imagine, if I spend half a grand and the problem persists. Now I happen to live on the sixth floor, and with the frustration I happen to be experiencing, it would be a parachuteless jump! I’ve re-installed 64Studio, this time with the recommended separate partitions, tweaked as much as I could in the BIOS, post-researching the topic, but it’s all one big calamity. Tried doing a rhythm track with Hydro but got lost as it was ‘Zombified’. Also, if I start Jack, then Ardour, and then Jamin, Jamin crashes and everything gets disconnected. I get loads xruns stating delays in ms, but at my level of knowledge, a log window looks like an online lesson in Cantonese. Jacks frames are set at 1024, so it’s not like I’m pushing it.
Actually, I’ve been using 64Studio & Ardour for more than a year, but all I’ve required it to do in the recent past, is to record a single stereo track of music completed on my Roland VS1880 HD recorder. If you want, you can hear some of this stuff on . Nonetheless, I would have liked to make some entire pieces on Linux software for more than a few reasons. I hold some Marxist views, and as far as I’m concerned, Bill Gates has done as much for the world as Benito Mussolini did for Italy or Genghis Khan for China. However I don’t want to go off a tangent. At the moment, I feel I’m stuck in a rut, my guitar chops are suffering and my art neglected. Could it not be that Ardour and other audio facilities are sharing resources with other less important applications, e.g spreadsheets, animation, etc. I wonder if I’ll ever know, well thanks anyway, all the best A>.

Hi, well that’s an idea, and a radical one too. Would I need to remove all the plugins at once, or just a few at a time? Let me tell you that I do suffer from all the tedious malfunctions even when not using the plugins. Also, I can build a Super Locrian mode from any given root, spell an E13b9 chord, and even recall a a C# note in the middle of a forest, but as to build something from source, well…??? Nope! Would I be left without not even a little reverb? Actually, I don’t use the included synths, that is, I play guitar synth and keyboars, would removing that stuff help? I might give it a shot, the management tool is not so haunting. Thanks for the suggestion, A.