Ardour 8/8.1 win 10 installation fails

Hello, I used to work with Ardour/Linux. Now, I have tried to install Ardour on Win 10 for a friend and it failed:

"Installer integrity check has failed. Common causes include incomplete download and damaged media. Contact the installer’s author to obtain a new copy.
More information at:

What can I do?

Thank you in advance
Zonk (Jürgen)

Screenshot 2023-10-20 145454

I haven’t gotten that error before while installing on Windows. Where did you download the installer? That webpage link on the error message appears to be related to Sourceforge, which isn’t used by the Ardour project. If you downloaded Ardour anywhere other than this website, try a copy provided here (even the demo) and see if you still get the error.

We do in fact use NSIS to create the Ardour installer.

@Zonk Have you tried downloading the installer again? Perhaps you do in fact have an incomplete download.

Sorry for posting wrong information, my bad.

1 Like

I have just checked, the installer works here without any issue.

To verify if you the download succeeded, verify one of the these the checksums:


b8a3ab293f49a3cd83742792d454c1907c41fc74  Ardour-8.1.0-demo-w64-Setup.exe
e3b1419411e0c007aed20957075e58ee2e2cc802  Ardour-8.1.0-w64-Setup.exe


898ff5e4ff2dacb3121f0ba2b4bbe078  Ardour-8.1.0-demo-w64-Setup.exe
f7eb963406fa405055899b12f22d7e2b  Ardour-8.1.0-w64-Setup.exe


b61159d8d209fa389f0fa90f2336d6d50bff0e8a2d211596fe4c3699de16d2fa  Ardour-8.1.0-demo-w64-Setup.exe
d29cf22005104166e6ca501bcf4071f4ebca5a4cdaa1f7d9a7ba7b0423492b98  Ardour-8.1.0-w64-Setup.exe

File size in bytes

85120731 bytes Ardour-8.1.0-demo-w64-Setup.exe
85118118 bytes Ardour-8.1.0-w64-Setup.exe

FWIW I tried with a nightly/full in Windows 11 and got a similar error message but not from NSIS or at least it didn’t tell so.
I suspect it’s the usual thing, it can’t verify the package origin and thus refuses to install. I could get by by clicking the “Show details” link which opened another cryptic line of explanation text and the option to install nevertheless. That’s missing in the OP screenshot so this is not extremely helpful, just my 2 cents

1 Like

The unsigned installer issue is different. That happens before the installer runs:

1 Like

Thanks you for your quick response Robin. Checksums are ok. I tried the installation again on another Windows computer and it worked. Strange, I can’t understand why it works on one Windows computer and not on another. I also had success with wine.

It’s a pleasant community here and I’m happy to be able to make my small contribution as a subscriber, thank you!

1 Like

It might be not related to your situation, but i experienced something similar a few years back. I had constantly corrupted files on my Desktop PC and i also played a Online Game and the launcher found constantly Game related, corrupt files and repaired them. It got so worse that if i copied files from one folder to another they where also corrupted.

Long story short: It turned out the RAM memory modules where faulty and after a replacement the problem was solved.

1 Like

Das Problem besteht nur unter Windows - mit Linux läuft es. Daher macht
es wohl wenig Sinn die Ram-Riegel zu tauschen.

Dennoch - vielen Dank!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.