Ardour 8.2 released

Ardour 8.2 is now available. Nothing incredibly dramatic for this release, but it completes our support for all current Novation LaunchPad devices (as well as the new SSL UF8 surface) and includes the usual collection of bug fixes, small new features and quality of life improvements.

Full release notes and download as usual.


Glad to have the boundary box fix, that was a cagy little spud and liked to sneak up in click-busy sessions…

Thanks, but the whatsnew page shows 7.5 changelog.

EDIT: Fixed now !

As usual I try to build from scratch on my Fedora system using the Fedora mock build system. Usually that works fine…
It seems that building Ardour 8.2 now requires the LibAAF libraries, and these are not officially available on Fedora. Is it possible to build ardour without aaf?

No, but you can just configure ardour without --use-external-libs.

True, but I like to see how ardour behaves with system libraries where possible.
Maybe I’ll dive in a bit deeper later.

Note that this only effects 4 (now 5) libs (Ardour usually statically links against those)

  • libltc
  • libfluidsynth
  • VAMP / qm-dsp
  • libhidapi
  • libAAF

The main reason for that option is to aid development of those out of tree libs. So we can first work upstream on those, before later copying them into Ardour’s source tree.


Thanks, and congrats :slight_smile:


Add workaround for yabridge threading.

I’ve noticed that the reported DSP usage seems unusually/unrealistically high (compared to reported CPU usage by the OS). I figured it could be related to a WINE plugin? Which issue is addressed in this case?

1 Like

This specific fix addresses Ardour freezes after load some plug-ins · Issue #266 · robbert-vdh/yabridge · GitHub

CPU usage is almost entirely unrelated to DSP load. DSP load is about how reliable realtime threads can be periodically scheduled.


I love that AAF is ongoing, I’ve been hoping for this for years now! :slight_smile:


Thanks a lot! Great work.

By the way, did any one try the new Note tupling feature mentioned in 8.2? I tried but unfortunately wasn’t able to make it work as expected.

1 Like

… works now after I ‘Reset Bindings to Defaults’. :thinking:

however, great function, thanks a lot!


I already bought it, but made a mistake yesterday, that destroyed it. How can I repair it?
I made a Re from a backup, but this is only with Ardour6…
Greetings from Berlin

Could you please be more specific? What do you mean when you say you destroyed it?

If you paid, you should be able to just log in and download the installer again.

Everything went fine in the Meantime. I don’t know how and why. :wink:

1 Like