Ardour 7 on M1 Pro - “” is damaged and can’t be opened. You should move it to the Trash

I just downloaded the official release of Ardour 7 on my M1 Pro MBP running macOS 12.6. I tried redownloading the file to the same result. See screenshot below. Any suggestions anybody? I have security preferences set to allow apps downloaded from anywhere, I do not think this is a gatekeeper issue, rather I think there is something wrong with the application bundle itself… Can anybody else test or verify this issue?

That is normal. The application is not digitally signed.
On BigSur (and later), after download the application has to be released from quarantine. In a Terminal window run

xattr -rd ~/Downloads/Ardour-*.dmg

Right-click (or control + click) and select Open the first time to launch it. For further information, see also information how to disable the gatekeeper.

Thank you for your help, Robin. This solved the issue. Maybe this info should be put in the download page?

1 Like

Thank you!

Yes, it should be better documented. So far it was mentioned on (until today, the only place to get Apple Silicon versions), but now it should be included on the download page and (really macOS now) – I’ll put it on the ToDo list.

I would make a suggestion this needs to be added as a background image on the DMG, it will be FAR to common an issue otherwise and needs to stare people in the face every time they try to download a new version of Ardour I suspect.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.