Ardour 7 GUI does not show up with KDE Plasma Breeze theme

Hello,

Fedora 37 user here, working with Ardour 7.1 as provided by the distribution (with Wayland and Pipewire, if it matters).
When setting the GTK application theme to Breeze rather than Default in KDE Plasma style settings (kcmshell5 kcm_style), the Ardour GUI never shows up. There’s no crash, but simply nothing happens anymore after this step:

Ardour: [INFO]: Loading color file /usr/share/ardour7/themes/dark-ardour.colors

It works if going back to Default.

I’m wondering if this is a bug with Ardour itself, with the way Fedora packages it, or with the system?

Apart from that, is there some environment variable I can use to set the GTK theme individually, as a workaround? I read something about GTK_THEME which does indeed change the theme for other apps, but setting it for Ardour didn’t fix the startup problem.

(For reference, here’s the KCM’s source code: kcms/style · master · Plasma / Plasma Workspace · GitLab)

Ah, it just came to my mind I can set the theme to Default in the system settings, and then export GTK_THEME=Breeze globally. This works to change the theme of other apps, while Ardour still starts normally.

But it’s strange all the same.

It’s not strange. It’s because your default system theme defines a color palette, and GTK+2 has a bug in it that makes it hang if two palettes are defined. Very few applications define a color palette, but Ardour does. Consequently, using it with that system theme hangs due to this bug in GTK+2 (which, btw, will never be fixed).

If you using a build from ardour.org, this will not happen.

1 Like

Thanks for your reply.

It’s because your default system theme defines a color palette

(It’s the other way round, Default works but Breeze doesn’t.)

I see the point with GTK color palettes, but what explains the difference between setting GTK_THEME=Breeze (ardour starts normally) and setting Breeze in the Styles KCM (ardour hangs)? Does ardour ignore GTK_THEME, unlike other GTK applications?

Apart from that, if I remember correctly, I had set Breeze in the Styles KCM on my two previous installations (ubuntu 20.04, opensuse leap 15.4) and ardour always started normally.

I can’t really comment on what a distro build of Ardour will or will not do.

The builds we provide at ardour.org completely ignore any and all system GTK settings.

OK. I’m fine with the workaround for now, anyway. Maybe I’ll write to Fedora packagers at some point.