Ardour 7 Can't Autostart ALSA Backend

Hey all. As the subject states, I’m finding that the “Autostart” option in the Audio/MIDI setup dialog (or Preferences>General>Try to auto-launch audio/midi engine) has no effect on a fresh install of Ardour 7.1.0, and I’m wondering how to go about troubleshooting this. I’ve tried starting Ardour from the command line but after the splash screen, no new messages are printed when the “Session Setup” or “Audio/MIDI Setup” dialogs appear. Anything else I could try? Are others running into this?

For a bit of context: I used to use Ardour with JACK so that I could route the output of external applications into Ardour tracks (along with recording physical instruments), but that configuration broke when my distro (Fedora) switched to pipewire–I never got Ardour working properly after the upgrade to Fedora 34. Last weekend I finally found the time to wipe my disk and perform fresh installs of Fedora 37 and Ardour 7.1.0, and things mostly worked!

However, while watching Unfa’s youtube interview with Paul (and reading Robin’s comments in the chat) I learned that there are apparently still issues with latency reporting in pipewire’s implementation of JACK, so I gathered that my best bet would be to stick with the ALSA backend for recording physical instruments. When I had Ardour 7 configured to use pipewire’s JACK, it started up without displaying the Audio/MIDI setup dialog. When configured to use ALSA, it shows the Audio/MIDI setup dialog every time, even when autostart is enabled. Thoughts?

Thanks!

Do you use different devices for input and output?

Thanks for the reply. I’m using a Zoom R24 for both input and output. I do have another device physically connected (Edirol UA-5), but Ardour’s not configured to use it.

Do you get a dialog “Engine I/O device has changed since you last opened this session.”?

and when you look at a .ardour session file the 4 line reads

<EngineHints backend="ALSA" input-device="None"  ...

If so, Ardour 7.1-178 (current git) should fix this.

I don’t recall seeing the dialog you describe, and when examining a recent .ardour session file, I see:

<EngineHints backend="ALSA" input-device="R24" output-device="R24"/>

Would you like me to report this as a new bug?

Yes, we’ll need more information then, and a ticket on the issue tracker is definitely better suited. Thanks in advance.