Ardour 7.1 OS-X certain plugins not loading

Hi,

Just installed Ardour 7.1.

So far so good, except I can’t seem to load the Eventide plugins BlackHole and ShimmerVerb. When I try to add them as an AU plugin, Ardour refuses and says “Could not convert CAComponent to CAAudioUnit” in the log.
When I try to load as VST3, Ardour just collapses and crashes.

These plugins worked fabulously in Ardour 6.9.

Any ideas? I rely heavily on those effects…

PS: I already scanned the plugins, rebuild cache, and have the latest Eventide updates installed. I’m on macOS Monterey 12.5.1.

SOLVED: Turn “Use translations” off in Ardour.

Today I tried this, because I remember having to do this in order for certain things to work in Ardour a very long long time ago. I think it was even Ardour 5 or so…

The Eventide Audio Unit plugins now load and show.

1 Like

That is an interesting find. What language does Ardour use when you enable translations?

One where a decimal separator is comma? 1,0 vs 1.0

I can confirm this finding. For me it affects Waves and Plugin Alliance plugins. With enabled translations the Waves plugins produce no sound, and when I want to change a parameter on the GUI, there is a ‘nan’ message. The Plugin Alliance bx_* plugins do not recognize that they are registered. With disabled translations both of them are working fine.
My macOS version is 12.6 (M1), and the system language is Hungarian. The decimal separator is comma. Ardour version is 7.1, with English language (independently from the “Use translations” checkbox).

Exactly that: the language seems to stay in English (Belgium is a trilingual country!) where according to my system settings (Flemish) Dutch should be activated. System also states 1,0 in stead of 1.0 as you remarked.

For the record, the next release (i.e. current codebase) will interpret your system language preferences differently. If you have, for example, en_BE:fr_BE, Ardour will no longer translate its text. We will see the en_BE first-place preference know that we have no Belgium-English specific translation (contrast, for example, with en_GB) and thus conclude that the user does not want translations. We will, however, still set the LC_ALL environment variable to define “locale”, based on whatever macOS says about your locale setting.

In the current and older releases, we would see en_BE, look for a translation, fail to find it, and then fall back on fr_BE.