Ardour 7.1 doesn't work with Waves Plugins v14?

Hey everyone,

since i updated to Ardour 7.1 (actually running on 7.3) my Waves plugins doesn’t work anymore.
I do see all my plug ins in the plugin manager, they are installed and status OK.
(Installed as AudioUnit)
When i use the Waves v14 plugins in the Project there’s in every plugIn overload and no Audio is coming through.
Ardour 6 is working normally.

System MacOS Ventura 13.2.1
Does anyone have/had the same issues?

Are you using the Intel version or the AppleSilicon version of Ardour? on a M1/M2 system?

I am using the Intel version of Ardour on Intel Mac 2019 i7 6-Core.

I have the same Problem. MacBook Air Late 2020 (Apple Silicon M1, Ventura 13.3.1). In Tracktion Waveform 11 everything works fine.

The common thing here seems to be that that both of you use a German system.
At some point in the past there was an issue with decimal separators. e.g. 1,3 vs. 1.3
Does it help to disable translations (Ardour Preferences > Appearance > Translations)?

PS. There have been various changes for VST3 plugins, since Ardour 7.3.
It might be useful to check out v7.4

1 Like

I was using Ardor 7.4 as I was posting. I misnamed my screenshot. I tried you advice (disable translations) and it worked! Thank you so much for this hint. :+1:

1 Like

Thank you. This is very useful information.

At this time it is unclear how to properly solve this, and why only the waves plugins are affected. I have filed a ticket, so that this issue won’t be forgotten:

1 Like

Following this thread/ticket. I am in the USA and my PC is running Windows 10. I am currently running Ardour 7.4 (but I encountered this issue when running 7.1). I have translations disabled and when I try to load a Waves plugin (despite all of them being populated after scans) it crashes Ardour. When it performed the initial scan for the plugins, it got hung up on “WaveShell1-VST-14.12_x64”. I had to skip to continue. I experience the same when rescanning for plugins. Interestingly, when I run Re-scan All it opens a stand-alone WavesHeadTracker plugin on its own and it is functional.

At least you can load the Waves plugins in Ardour, they freeze Steinberg Cubase 12 and I needed to force close it.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.