Ardour 6 on Ubuntu 20

Hi!
I’d like to use Ardour 6: I’ve just updated Kubuntu to 20, and I see that Ubuntu Studio decided not to propose A6 in the repos. So I installed backport repository
ppa:ubuntustudio-ppa/ardour-backports
(I’m not using Ubuntu Studio, but Kubuntu with KX repositories)
but then the software manager (muon) shows ardour-data 6, but ardour remains 5.12.
Maybe this helps:

~$ apt-cache showpkg ardour
Package: ardour
Versions: 
2:5.12.0-1kxstudio2v5 (/var/lib/dpkg/status)
 Description Language: 
                 File: /var/lib/dpkg/status
                  MD5: ca07a57a6bf81c5ab213fc869c4ba6fb

1:6.2.0+ds1-1~ubuntu20.04.1 (/var/lib/apt/lists/ppa.launchpad.net_ubuntustudio-ppa_ardour-backports_ubuntu_dists_focal_main_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/ppa.launchpad.net_ubuntustudio-ppa_ardour-backports_ubuntu_dists_focal_main_binary-amd64_Packages
                  MD5: c8bc2c12b9131ae879ae840a96954b51
 Description Language: en
                 File: /var/lib/apt/lists/ppa.launchpad.net_ubuntustudio-ppa_ardour-backports_ubuntu_dists_focal_main_i18n_Translation-en
                  MD5: c8bc2c12b9131ae879ae840a96954b51

1:5.12.0-3ubuntu4 (/var/lib/apt/lists/ch.archive.ubuntu.com_ubuntu_dists_focal_universe_binary-amd64_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/ch.archive.ubuntu.com_ubuntu_dists_focal_universe_binary-amd64_Packages
                  MD5: da4b23920a85356ff3a27154c8159a99
 Description Language: en
                 File: /var/lib/apt/lists/ch.archive.ubuntu.com_ubuntu_dists_focal_universe_i18n_Translation-en
                  MD5: da4b23920a85356ff3a27154c8159a99


Reverse Depends: 
  ardour-data,ardour 1:4.2~dfsg-1
  ardour-data,ardour 1:4.2~dfsg-1
  ardour-data,ardour
  ardour-data,ardour 1:4.2~dfsg-1
  kxstudio-recommended-audio,ardour
  ubuntustudio-audio,ardour
  multimedia-recording,ardour
  multimedia-mixing,ardour
  multimedia-looping,ardour
  multimedia-audio-utilities,ardour
  multimedia-ambisonics,ardour
  invada-studio-plugins-lv2,ardour
  invada-studio-plugins-ladspa,ardour
  games-content-dev,ardour
  ardour-data,ardour 1:4.2~dfsg-1
  ardour-data,ardour
Dependencies: 
2:5.12.0-1kxstudio2v5 - lv2-dev (0 (null)) ardour2 (0 (null)) ardour3 (0 (null)) ardour4 (0 (null)) ardour2 (0 (null)) ardour3 (0 (null)) ardour4 (0 (null)) 
1:6.2.0+ds1-1~ubuntu20.04.1 - ardour-data (2 1:6.2.0+ds1-1~ubuntu20.04.1) ardour-data (3 1:6.2.0+ds1.0~) libarchive13 (2 3.0.4) libasound2 (2 1.0.16) libatkmm-1.6-1v5 (2 2.24.0) libaubio5 (2 0.4.3) libc6 (2 2.29) libcairo2 (2 1.2.4) libcairomm-1.0-1v5 (2 1.12.0) libcurl3-gnutls (2 7.25.0) libcwiid1 (2 0.6.00+svn184) libdbus-1-3 (2 1.9.14) libfftw3-single3 (2 3.3.5) libfluidsynth2 (2 2.0.5) libfontconfig1 (2 2.12.6) libgcc-s1 (2 3.4) libgdk-pixbuf2.0-0 (2 2.22.0) libglib2.0-0 (2 2.31.8) libglibmm-2.4-1v5 (2 2.54.0) libgtk2.0-0 (2 2.24.0) libgtkmm-2.4-1v5 (2 1:2.24.0) libjack-jackd2-0 (18 1.9.10+20150825) libjack-0.125 (0 (null)) liblilv-0-0 (2 0.22.0~dfsg0) liblo7 (2 0.26~repack) liblrdf0 (2 0.4.0-1.2) libltc11 (2 1.2.0) libpango-1.0-0 (2 1.22.0) libpangocairo-1.0-0 (2 1.14.0) libpangoft2-1.0-0 (2 1.14.0) libpangomm-1.4-1v5 (2 2.42.0) libpulse0 (2 0.99.1) libqm-dsp0 (0 (null)) librubberband2 (2 1.8.2) libsamplerate0 (2 0.1.7) libsigc++-2.0-0v5 (2 2.8.0) libsndfile1 (2 1.0.20) libstdc++6 (2 9) libsuil-0-0 (2 0.6.0~dfsg0) libtag1v5 (2 1.9.1-2.2~) libusb-1.0-0 (2 2:1.0.16) libvamp-hostsdk3v5 (2 2.9.0) libvamp-sdk2v5 (2 2.9.0) libwebsockets15 (2 3.2.0) libx11-6 (0 (null)) libxml2 (2 2.7.4) ardour3 (3 1:3.5) ardour-video-timeline (0 (null)) ardour3 (3 1:3.5) 
1:5.12.0-3ubuntu4 - ardour-data (2 1:5.12.0-3ubuntu4) ardour-data (3 1:5.12.0.0~) jackd (0 (null)) libarchive13 (2 3.0.4) libasound2 (2 1.0.16) libatkmm-1.6-1v5 (2 2.24.0) libaubio5 (2 0.4.3) libc6 (2 2.29) libcairo2 (2 1.2.4) libcairomm-1.0-1v5 (2 1.12.0) libcurl3-gnutls (2 7.25.0) libfftw3-single3 (2 3.3.5) libfluidsynth2 (2 2.0.5) libfontconfig1 (2 2.12.6) libgcc-s1 (2 3.4) libgdk-pixbuf2.0-0 (2 2.22.0) libglib2.0-0 (2 2.31.8) libglibmm-2.4-1v5 (2 2.54.0) libgtk2.0-0 (2 2.24.0) libgtkmm-2.4-1v5 (2 1:2.24.0) libjack-jackd2-0 (18 1.9.10+20150825) libjack-0.125 (0 (null)) liblilv-0-0 (2 0.22.0~dfsg0) liblo7 (2 0.26~repack) liblrdf0 (2 0.4.0-1.2) libltc11 (2 1.2.0) libpango-1.0-0 (2 1.22.0) libpangocairo-1.0-0 (2 1.14.0) libpangoft2-1.0-0 (2 1.14.0) libpangomm-1.4-1v5 (2 2.42.0) libqm-dsp0 (0 (null)) librubberband2 (2 1.8.2) libsamplerate0 (2 0.1.7) libsigc++-2.0-0v5 (2 2.8.0) libsndfile1 (2 1.0.20) libstdc++6 (2 9) libsuil-0-0 (2 0.6.0~dfsg0) libtag1v5 (2 1.9.1-2.2~) libusb-1.0-0 (2 2:1.0.8) libvamp-hostsdk3v5 (2 2.9.0) libvamp-sdk2v5 (2 2.9.0) libx11-6 (0 (null)) libxml2 (2 2.7.4) ardour3 (3 1:3.5) ardour-video-timeline (0 (null)) firefox (16 (null)) www-browser (0 (null)) jamin (0 (null)) qjackctl (0 (null)) ardour3 (3 1:3.5) 
Provides: 
2:5.12.0-1kxstudio2v5 - 
1:6.2.0+ds1-1~ubuntu20.04.1 - 
1:5.12.0-3ubuntu4 - 
Reverse Provides: 

Thank you!

We do not and cannot support builds of Ardour provided by Linux distributions. In the case of some distributions, we actively discourage the use of their build.

You can always install the build from http://ardour.org/download which can be installed in parallel with any distro-provided version.

2 Likes

Ok, I think you wont list the distributions :innocent:
Anyway, I had already downloaded your package, but I thought it was easier to install the KX package for update reasons. Now if I can use both, it’s nice, I can still load my old sessions in V5.12 for any compatibility issue.

thank you Paul!

There’s a few ways to hold a package back from being “upgraded” after installing 6 from backports. Search for apt hold if you do your updates from the terminal. Synaptic has another way. You’ll find it :slight_smile:

thank you nSpud3,
I finally install from the official .run, it works and I’ll continue to use 5.12 for older projects.

I just pay to buy Ardour 6.0 and do not know how to install the file in .run

Well make the file executable (right click properties and there must be a tickbox somewher) or via a chmod (sorry dont remember the right command line)via your cli.

Then launch the .run script via your cli.

Many thank. Get done

That was a pleasure !

We did you ask/suggest that you read http://ardour.org/first_time_linux.html which has full instructions.

By the way, how could I get Ardour in the latest version. I am using Ubuntu Studio and normally the function (apt update / upgrade) to update all programs

We do not (and cannot) support distribution provided versions of Ardour.

The official version is always at https://ardour.org/download and can be parallel installed with distribution provided versions.