Ardour 6.9.0 on fresh Debian Bullseye

Hello there
The Ardour package version for Debian Bullseye is 6.5.0+ds0-1 (6.9.0 will come with Debian 12)
I tried to build and install Ardour 6.9.0 on a fresh Debian 11 : all seems to be ok (even if there are some warnings)

Here my method for those who would be interested in:

 cd ~/Downloads/
 bunzip2 Ardour-6.9.0.tar.bz2                       
 tar xvf Ardour-6.9.0.tar    
 
 sudo apt-get update
 sudo apt-get install --yes python-is-python2 gcc-10 gcc clang-11 g++
 
 sudo apt-get install  --yes libboost1.74-dev libasound2-dev libpulse-dev libglibmm-2.4-dev libsndfile1-dev libcurlpp-dev libarchive-dev liblo-dev  libtag1-dev  vamp-plugin-sdk librubberband-dev libjack-jackd2-dev libudev-dev libfftw3-dev libaubio-dev libxml2-dev liblrdf0-dev libcurl4-gnutls-dev libcwiid-dev libusb-1.0-0-dev libwebsockets-dev libpangomm-1.4-dev libsamplerate0-dev lv2-dev libserd-dev libsord-dev libsratom-dev liblilv-dev libcppunit-dev libsuil-dev libsoundtouch-dev libgtkmm-2.4-dev  libdbus-1-dev libreadline-dev 
 
 sudo apt-get install --yes libcanberra-gtk-module
 
 sudo apt-get install --yes xjadeo  fluid-soundfont-gm drumgizmo calf-plugins x42-plugins guitarix-lv2 swh-lv2
 
 /waf configure

 ./waf
 
sudo ./waf install

Then you can run ardour 6.9.0 in command line


ardour6

And try some tutorials :wink:

Bye

2 Likes

yeah! i use compiled version too. i just add --optimize to waf configure to get optimized binaries.

You can simplify the dependency setup step:

sudo apt-get build-dep ardour
# except debian does not  [yet] list libreadline as build-dependency
sudo apt-get install libreadline-dev

We recommend against running waf install, mainly because there is no reliable way to uninstall it.

You can simply run Ardour from the source-tree

./gtk2_ardour/ardev

Thank you, I’ll do like this next time
And Thanks to docksudbbs

I have already tried the ardev way, but I noticed CPU usage is higher than with the install way.
And I don’t want to uninstall Ardour :wink:
So the install way seems to be ok for me

Thanks Robin

It is not possible for the CPU usage to be higher. It’s the exact same code, just run from a different location.

Hi Paul
:thinking: It was on a low conf PC, 4GB RAM without SSD. Maybe that could be checked with strace (for instance, I think about LD_LIBRARY_PATH : lib paths are nearer in /usr/local, and there are less system calls to reach them).

Am I the only one who tried this ?

Neither RAM nor disk-i/o (HDD vs SSD) have any impact on CPU usage.

So this is mysterious. Perhaps you’re comparing a non-optimized local build with a distro’s optimized one (rather than running the one in /usr/local)

You may want to update it at one point though.

Thanks Robin
That keeps mysterious for me. It’s was on an older version of 6.x…Let’s forget this.

You’re right : i’ll want to update :slight_smile:

To build , I used ardour - the digital audio workstation and that was not clear for me that using ./waf install wasn’t a good idea (simple RTFM killed me :wink: )

The “problem” is that to uninstall you have to run ./waf uninstall with exact the same configuration and version that you have installed. If you meanwhile git pull or re-run ./waf configure ... with different parameters, uninstall may not work or leave some files behind.

This is known to have caused issues in the past when different versions have been mixed.

Thanks Robin

That will be ok for me because I don’t use the git way : I download the zip of each version and I keep it unzipped in a directory like “Ardour-6.9.0”, so I keep the configuration and I can properly uninstall.