Ardour 6.7 crashes when trying to start session - Mint Uma

I upgraded to Mint Uma. Ardour 5 worked at first but started crashing when trying to open/create session. Upgraded to Ardour 6.7 and am having the same problems. I have the crash report. I am running Jack 0.5.0

Evidently the crash report is too long for this and I am a new user, therefore it will not allow me to enter anything with more than 2 links. I can post the relevant parts of the crash report if pointed in the right direction. Any help would be greatly appreciated.

(edit)I get a SIGABRT and the following
…/sysdeps/unix/sysv/linux/raise.c: No such file or directory.

The usual reply from the developers is check with the official binary from this site. If you are running 6.7 then it sounds like you are running the version from the distribution, since 6.9 is the latest version from here.
Mint is based on Ubuntu, and it seems like Ubuntu breaks something every other release. The version from here is very likely to run with no problems.

Uma…

Perhaps a similar issue as Ubuntu 18.4 and 20.4:

try:

sudo dpkg -P csladspa calf-ladspa

Thanks for the replies, gang. I appreciate the help but I found the problem. Jack was running in Realtime. Turned Realtime off and now everything is running great.

P.S. I ran the dpkg command and that may have helped as well.

Err no, you just found the symptom. Your system is not set up for realtime performance there and that is a problem, and that should be fixed, otherwise any recording will be unreliable AT BEST.

https://jackaudio.org/faq/linux_rt_config.html

   Seablade

You are absolutely correct. Ardour started crashing again. I noticed that it always crashed when loading the plugins. I noticed that the last message was while loading LV2 plugins. Deleted them all from the /usr/lib/lv2 directory after making a backup of it ( don’t know why I installed them all, I don’t need them ) and put 1 back in that I know I want and need, Calf, and now it starts up fine. Over and over again. Seems I may have had a corrupt plugin. Don’t know why it would load them and then not load them intermittently though. Thought I saw something about a bug fix in 6.9 with loading plugins.

Calf in general is probably the single largest source of issues for users from plugins on Linux. The dpkg command Robin gave you above actually removes some particularly problematic packages that are LADSPA versions of the calf plugins that caused crashes on plugin scan at startup in other distributions in fact. Be very wary using them in general.

That being said, my comment about needing to set up your system for realtime privileges above still applies.

   Seablade

Yes, I did that and everything is working realtime.