Ardour 6.3 - Cannot import (most) MIDI files

Hi I have downloaded Ardour 6.3 and I cannot import most MIDI files. I have tried to rename the ladspa and the lv2 folders as suggested by some users but Ardour 6.3 still crashes when importing most MIDI files. I have the same problem in Safe Mode (no plugins). Any suggestion?

On a daily basis, I still use Ardour 4 which works flawlessly. I’m on Ubuntu Studio 16.04.


One or both of:

  1. file a bug report, and attach one or more of the problematic MIDI files

Safe mode only does not instantiate plugins when loading a session, but you can later add plugins just fine.

When you Import the MIDI file, select Instrument: -none- in the import dialog, and see if that makes a difference.

Thank you. I have already filed a bug report (0008444). And now I am trying to create a backtrace but I don’t know how to install the gdb program. I have a “core” file and I downloaded a file called gdb-9.2.tar.xz.sig. How do I install this debugger?

gdb is s standard Linux system tool. Install it using the software management tools provided by your distribution.

The files will load when I select “Instrument - none-”.

What were your typical choices for “Instrument” when not using “None” ?

In Ardour 6.3, I see General MIDI Synth. In Ardour 4, the default is Reasonable Synth.

I will attach the GDB output below. Oops, I cannot attach file here. I will attach it to the bug report.
I get several error messages like :
#0 0xb7ee7cf5 in ?? ()
Backtrace stopped: Cannot access memory at address 0xb585348d

You need a debug build (demo is fine), and ideally run Ardour in gdb Ardour6 --gdb

Does it work if you later add “General MIDI Synth” to the MIDI track?

No, the program crashes instantly when I add General MIDI Synth.

I have installed the debug version. I then opened gdb. How can I run the debug version within gdb now?
By the way, the Debug version can load the MIDI files without problem (!!!). Strange enough.

Well at least that explains your issue. It is however mysterious. Have you manually installed that plugin or got it from your GNU/Linux distro?

Do you use Ardour from or (those do come with a recent version of gmsynth.lv2)?

I got the plugin when I installed Ardour 6.2 last summer, I guess.

I got Ardour 6.3 from

Today I have installed the Debug version from and, strange enough, the Debug version does not crash when I import MIDI files.

Hi, Robin, I can import MIDI files when I select “None” for the instrument. Then I can add a-Fluid synth or a-Reasonable synth and even Calf Fluidsynth without crashing Ardour, but General MIDI Synth will crash Ardour. The problem might be with General MIDI Synth? Are there other synths I can use?

I have finally upgraded from Ubuntu 16.04 to 18.04 and renamed the ladspa folder to ladspa TEST and now Ardour 6.3 seems to work fine, I can now import MIDI files that play with General MIDI Synth.
Some plugins still seem to crash Ardour and I will now try to find the problem.

Any plugin CAN crash the system sadly, it is a drawback of plugins that they have the capability of crashing the host. Some hosts choose to process isolate the plugins to help prevent a plugin from taking down the host, but it doesn’t tend to scale well into the larger sessions that Ardour can get used for.

At any rate it is a question as to which plugins. For instance if you come back and say ‘Calf plugins cause a crash’ I would, at the moment say, that sounds about right. There are, however, many good plugins that operate fine and won’t crash the host, so finding the right ones can make all the difference.


Everything used to work fine in Ardour 4 though and by upgrading Ubuntu
from 16.04 to 18.04 my Ardour 4 was replaced by Ardour 5. Can I still get
Ardour 4 from the website?


We do not make older versions of Ardour in prebuilt form. It is possible to build any version but that’s an entirely different process. We are currently at version 6.3 with version 6.4 expected out soon.