Ardour 6.2.0 crashes when importing a MIDI file

I’ve tried many times to import MIDI files into Ardour 6 and Ardour quits instantly. I’m on Ubuntu 16.04.
The file loads perfectly into Ardour 4. Any suggestion?

ht

Please file a bug report, ideally attach the .mid file that causes the issue
at tracker.ardour.org – Thanks.

1 Like

Does it always crash with any midi file, or just some specific files?

The following ones work here with Arodur 6. Might be useful for a quick test:

I could load your files “notesweep.mid” and “velocitysweep.mid” without a
problem, but Ardour crashes when loading your file “mf_Beethoven5.mid”.
I’ve tried other MIDI files I have, some load and some make Ardour crash.

Here’s one file that makes it crash. It’s a very simple MIDI file, 2 piano
tracks. It loads fine in Ardour 4, which I have been using for quite some
time and I love it, but I wanted to test Ardour 6.

Thanks for your help!

Henri

(Attachment auclaird.mid is missing)

You cannot attach .mid to an email response, but have to upload it somewhere (e.g. google-drive, drop-box or similar) and then link to it.

OK, here’s the link to my MIDI file :

It loads OK into Ardour 4.

It also loads and plays just fine here in Arodur 6.0 and 6.2.
What synth plugin are you using when importing the file? Can you try setting that to “-none-” to rule out that it’s an issue with loading multiple synths.

PS. I’ve tested with general-midi synth (comes with Ardour 6).

The file will open in Ardour 6 when selecting “None” for the synth. Once
loaded, if I try to select a synth plugin the program quits instantly.

At least, I can use Ardour 4 to use MIDI. I am using Ubuntu 16.04, which is
a few years old. I wonder if it could be a factor?

Thanks again for your help.

Henri

Aha, so it’s a problem with the synth. – Which synth plugin are you using?

I have tried with a-Reasonable synth and also Calf Fluidsynth, but both
crash the program.

Thanks,

Henri

I could see calf plugins causing cashes, but a-reasonable synth?

Ubuntu 16.04 in general should be fine, except perhaps some issues with (older) plugins.

The only way to get to the bottom of this would be with a debug build (demo is fine) https://nightly.ardour.org and getting a backtrace: https://ardour.org/debugging_ardour

Today, I turned on my computer and I tried again to load the MIDI files
that made Ardour 6 crash and now EVERYTHING WORKS FINE! It was as simple as
restarting the computer.

I’m sorry for the trouble it may have caused you and thanks again a lot for
your help.

Henri

Today I was trying to import a MIDI file into Ardour 6.3.0 and, again, Ardour crashes (quits). I can open the file if I select “None” for the instrument, but it crashes when I select a synth. I tried to restart the computer like I did in July, but it didn’t work this time. Again, the file opens fine in Ardour 4.

P.-S. I downloaded the Debug version of Ardour 6.3.177 and the MIDI file opens and plays fine.

P.P.-S. Ardour 6.3.0 also quits when I try to open a file created with the debug versioin.

Three months later, I have the same problem importing MIDI files with Ardour 6.3.0. Strangely, the debug version works fine, so I cannot debug the problem. Ardour 6.3.0 also quits when opening files created with the debug version.