Ardour 5 won't export after "unfreezing" some tracks

Hello folks,
on a project I was working today, the DSP load was almost 100% all the time and I couldn’t work. So I ‘freezed’ some tracks to get the job done and exported the audio. It was the first time I used the “freeze” function so I didn’t know that I had to unfreeze the tracks so they could be exported properly.

After hearing that the “freezed” tracks were not exported I unfreezed them and tried to export the audio again. But when Ardour came to the point where it “analyses the exported audio” it just hanged at about 20%.
I tried exporting the project again but Ardour doesn’t do anything at all now. Not even exporting before analysing. It’s like hanging but not crashing because I can hit the “stop export” button and go back to my project and keep working. It just won’t export.

Another funny thing is that now the DSP load is less than before. It acts a bit weird though cause it goes from 50% to 2,3% then up to 99% and back down, etc…

Has anyone experienced this before or has anybody an idea of what I may have done wrong?
Thank you,

p.s. I’m working on an old (upgraded) Lenovo ThinkPad R61i.
Ubuntu 14.04 LTS
120GB ssd
Intel Core 2 Duo CPU T9300 @ 2.50GHz x 2
RAM 4 Gb
Intel 965GM

There’s no particular reason why frozen tracks should not export.

The DSP load issues sound as if they might be related to plugins. What plugins are you using? What happens if you start in “safe mode” (all plugins disabled)?

I’ sure that the DSP load was related to plugins. I have 6 vocal tracks with their own EQ and I have all of them send to a bus with a Calf Reverb and Echo. Before using busses I couldn’t work at all cause I have a (3 man) brass section, each with their own EQ, and previously they all had their own reverb so I used a buss for them too.
But I can’t explain why there is this up and down with the DSP load after unfreezing the tracks again. Surely it’s better than previously where the DSP load was almost constantly at 100%.

DSP is not exactly my biggest problem right now. The main thing is that I was just about done and after unfreezing 4 or 5 tracks I couldn’t export anymore…

It’s a 19 track project + 2 busses.
Other plugins I’m using on this project are saturation in a few tracks, a bass enhancer, some compressors and maybe 1 or 2 more. Nothing extraordinary. (maybe it is for my laptop)

Sorry forgot to tell you about starting the project in safe mode.
In safe mode with all the plugins disabled the DSP load was constantly under 5% and I could even export.

I restarted the project again but this time with the plugins enabled and had the same problems again.
So I guess it’s a plugin related problem overall?!

Should I enable them one by one and try exporting each time?

It is clearly a problem caused by 1 or more of the plugins you are using. There’s no way to find out which one other than testing them all one by one. Another reason to hate plugins … :frowning:

One other possibility is that you still have an old version of Jack2 installed on your Ubuntu 14.04 system which has bugs which cause export to fail (non-deterministically, and more likely under heavy DSP load conditions).

I have the QjackCtl from the software center installed which is version 0.3.10
Don’t know if and how I should update.

QJackctl is not JACK. QJackctl is just a GUI front end to make it easier to start/stop/configure JACK. To find the version of JACK either use your software update manager, or in a terminal run: jackd --version

Sorry my bad. My version is 1.9.10

Most likely it is a problem with jack2, then. One way to confirm this is to use Ardour’s ALSA audio-system (to export) instead of JACK. (Menu > Window > Audio/MIDI setup)

When opening my project in safe mode Ardour won’t let me enable the plugins in order to see which ones are causing trouble so I opened my project in ‘normal mode’ again and deactivated all the plugins.

I’ve started activating them one by one exporting each time my project until I realized that when I was activating a plugin in one of the tracks that had been “freezed” and “unfreezed” the same problem occurred!

I figured that I had to delete them and insert them from the beginning. In order to not lose all the settings of these plugins I tried to copy-paste the plugins in the same track and deleting the old duplicates but that had the same result: No export!

So the only workaround I’ve found is to delete all the plugins in those previously frozen tracks and insert them from scratch.
It worked with the first one. I even did export the project. I just have to do this with 4 more tracks and their plugins.

Frustrating but I know at least what caused the problem (without knowing why or what the problem is) and so I know not to do that again in the future.

As far as I understand it was the “freezing/unfreezing” tracks that caused the problem with their plugins.
It wasn’t the plugins alone. The same plugins are used in other tracks too but I didn’t freeze them and they didn’t cause any problem.

jack2 freezing on export correlated with the DSP load (the higher the load, the more likely to hit the bug). Then again Ubuntu 14.04 also ships a whole load of substandard plugin builds (particularly calf-plugins from 14.04 are known to regularly cause issues). Most of those issues have meanwhile been resolved.

If this is still an issue with recent versions, we need specific information (which plugins…) and a recipe to reproduce, otherwise it’s unlikely anything will change.

Funked Up: Also, what version of Ardour are you running and where did you get it from? But yes try the ALSA backend and see if that makes a difference on your export.r


How old are those Calf plug-ins?
Wasn’t there an issue with those in recent times?