Ardour 5 -- Region Colors and Playback

(Saam R Sany) #1

So I finally started using Ardour 5 on the reg (I know, I know…) and I have two issues…

  1. How do I get regions to have the color of their respective track in the Editor window? The tracks are assigned whatever color (it shows at the top of their channel strip in the mixer) but all my regions are just gray.
  2. In Ardour 4, if I click the rewind button (I don’t know what it’s called properly) while the session is playing, it would go to the start of the track but keep playing. In Ardour 5 it stops playback. Is there a preference/setting somewhere to change this behavior?

Otherwise, I’m happy I finally switched over. It looks great and definitely seems to be more stable. Thanks, @x42 for calling me out on my fear on change :smile:

(Edouard S.) #2

Hi,

for 1) you should check your preferences : in the preferences window, Editor > General > Region color follows track color should be checked.
For 2) I don’t think it can be done without lua scripting. You can check Auto Play in the Transport main menu, but this will start playback every time the playhead is moved. Or use the keyboard shortcuts for each action : home then space.

The (untested !) Lua Script would be like :

ardour {
	["type"]    = "EditorAction",
	name        = "Rewind and Play",
	author      = "drsaamah",
	description = [[Goto start of session and play.]]
}

function factory (params)
	return function ()
	    Session:goto_start()
        Session:request_transport_speed(1.0, true)
	end
end

Note that it seems that the future 6.0 version will have this enabled by default, i.e. rewinding will not stop the playback.

1 Like
(Saam R Sany) #3

Hey thank you so much. I don’t know how I missed that, I know I checked that menu ten times. So I’ve never done any lua scripting for ardour before. Do I save the text file somewhere specific in the filepath and it’ll just load up? Or…? I could also just use “Home” + “Spacebar”, I suppose. Just need to break an old habit I’ve been using for years, hah. Thanks again!

(Edouard S.) #4

Hi,
first, my script, tested, doesn’t work :sweat_smile:. This one does:

ardour {
["type"]    = "EditorAction",
name        = "Rewind and Play",
author      = "drsaamah",
description = [[Goto start of session and play.]]
}

function factory (params)
    return function ()
        Session:goto_start()
        Editor:access_action("Transport","ToggleRoll")
    end
end 

You have to save it as a .lua file and put it in the script folder:
GNU/Linux : $HOME/.config/ardour5/scripts
Mac OS X : $HOME/Library/Preferences/Ardour5/scripts
Windows : %localappdata%\ardour5\scripts
(create it if it doesn’t exist).

Then in Edit > Lua Script > Script Manager, select “Action 1” in the Action Scripts tab, then click the “Add/Set” button, choose your lua script (“Rewind and Play”) then “Add”.
You can now click the “1” button at the right end of the toolbar (if you have checked at least “Column 1” in the preferences > Appearance > Toolbar).
To bind this e.g. to the HOME key, open the Keyboard Shortcuts window (ALT K or menu Window > Keyboard Shortcut). With the search field, look for “Rewind and Play” in the Editor section of the Editor tab, and assign the HOME key, after removing it from the Global > Transport > Go to start action.

That seems a lot of work compared to home+space :slight_smile: but every step makes sense, and obviously we’re using the hugely powerfull scripting power of Ardour only to run a very simple macro.

Regards,
Edouard