ardour 5 // preferences window broken


i’ve just installed nightly build

when i try to access the preferences window, all the main links on the left (Misc, Transport, Editor, etc) are there but no links to the actual settings or any way to change settings appears.

i’m running debian 8.

thanks for any help on this!


Screenshot please. Nobody has reported such behaviour before. Use an image hosting site as necessary, such as

hi paul

thanks for your reply.

here’s the link to a screenshot, sorry to have forgotten that:


You should not be using the gcc5 build on Debian Jessie. That platform uses gcc4 (I use it myself). It is actually amazing that you even got it to run at all.

thanks for your reply. when trying to install the gcc4 version i get the following message in the terminal:

also, installed on my system are gcc-4-base, gcc-5-base and gcc-6-gase. i’m using a “testing” version of jessie (8).

should i go ahead and install the gcc4 version, despite the warning in the terminal?

ok, so i’ve now installed but i still have the same problem with the preferences menu: there are no settings available, only links on the left.

one other thing: is there no non-nightly build of the 32-bit linux intaller available? i’m only seeing a 64-bit installer. perhaps the problem is with these nightly builds?


Where are you looking? Most people should be downloading from and the first page offers a 32 bit architecture option.

thanks. now with the “stable” 32 bit installer the preference window is working again. don’t know why i missed this link for the 32 bit installer…i’ve been using ardour for over ten years now! i guess the nightly build i was using somehow wasn’t working with my system.

now, i look forward to getting acquainted with the new version. keep up the great work!

I have the exact same problem in Ardour 5. Installed it yesterday through the kxstudio repositories on 64-bit AVLinux 2016.

@mortenulysses: @jaskah notes that his problem went away when he installed our release build.

I had this problem too once Ardour 5.0.5 on debian 8.
I tried several things…
and I rebooted, and the problem was gone. (sorry, I don’t have a screenshot)

Couldn’t it be a but involving display drivers or video acceleration?

I experienced the problem with this version:
bind txt domain [gtk2_ardour5] to /opt/Ardour-5.0.5/share/locale
Ardour5.0.5 (built using 5.0-5-gfc272ef and GCC version 4.4.7)