Ardour 5 no playback

I’m running Elementary Linux on a 2014 MacBook Pro with Ardour 5 and QJackCtl. I can’t get any audio playback although I can see I’ve recorded something on a track (just clicking my fingers using the built in mic) and on playback the VU meter on the main out is pulsing up and down with my finger clicks. I’ve added these lines to the config file:-

@audio - rtprio 95
@audio - memlock unlimited

. . . . and created an audio group and added myself to it.

No audio output at all. Any ideas please? Thank you

Richie

Check the routing, make sure the track connected to the master bus, make sure the master bus is connected to the audio interface.
You mention QJackCtl, are you actually using jackd? Try using the ALSA native backend of Ardour, it is often easier to get configured properly.
You did not give any details of how you attempted to configure the audio interface, my first blind guesses would be that the master bus is not connected to the audio interface for some reason, or you have two audio interfaces, and the output is going to the one you do not intend to use.

Hi Chris

Thank you so much for your response.

How do I check the master bus is connected to the audio interface please? I’m totally new to Ardour so don’t know my way around.

Thanks

Richie

OK. So the issue is after that. First check that master-out is connected:

Next check that Ardour (or JACK) uses the correct output device. In a terminal window run

cd /tmp && wget https://community.ardour.org/files/adevices.sh && bash ./adevices.sh

It will not modify your system; it lists all soundcards, their current settings and applications using them, etc. Then copy+paste all the output of that script and paste it here (unless you can interpret it for yourself… which device is used by jack/ardour)

If the correct device is used, another possibility is that the soundcard’s hardware mixer is muted. Check with alsamixer (<F6> to select the device).

Last but not least, check if the amp or speakers are turned on…

Hi and thanks for your suggestions.

I checked the Master Output and it’s going to playback 1 and playback 2

I checked the audio track and the output is going to the master.

I ran the script in terminal and got a heap of stuff!! Here’s a small selection. I’m not too sure what I’m looking for here?

Part I: ALSA
Advanced Linux Sound Architecture Driver Version k5.4.0-77-generic.

Card 0 (PCH):

  • Playback Device 0 (CS4208 Analog):

    • Subdevice 0 (hw:PCH,0,0):
      used by: jackdbus (PID 8604)
      access: MMAP_INTERLEAVED
      format: S32_LE
      subformat: STD
      channels: 4
      rate: 44100 (44100/1)
      period_size: 1024
      buffer_size: 2048
  • Playback Device 1 (CS4208 Digital):

    • Subdevice 0 (hw:PCH,1,0):
      closed

The term “PCH” is used by Intel to refer to the interface chip between the processor and other system components, so PCH would typically be the built in audio interface. That device is being used by jackd.

Does that match what you expected, i.e. you intended to use JACK backend and send audio to the built in audio interface?
If so, the next suggestion would be the place to check, make sure the interface does not have a software volume control turned down or muted. You can use alsamixer, which is a console application, but there are probably other graphical applications available on your distribution as well.

Hi

I’m still having no luck. I am using Jack and QjackCTL. It’s so frustrating. I can see the VU meter on the master out responding to the audio I’ve recorded but it isn’t audible through the speakers. For info I’m on a MacBook pro running Linux Elementary.

All the output below I just can’t understand. There must be simple solution?

Richie