Ardour 5: "could not create session"


I’m facing problem to create new sessions after installing Ardour-5.0.5. I receive a message “Could not create session in <session_path>”.

Additionally, as I opened Ardour5 via console, here it is the output collected.

ERROR: JACK: Cannot use real-time scheduling (RR/5)(1: Operação não permitida)
ERROR: JACK: JackClient::AcquireSelfRealTime error
INFO: Loading keybindings from /opt/Ardour-5.0.5/etc/ardour.keys
INFO: Loading bindings from /opt/Ardour-5.0.5/etc/ardour.keys
Loading menus from /opt/Ardour-5.0.5/etc/ardour.menus
ERROR: JACK: Cannot create thread res = 1

Also there’s a screenshot of the problem:

Does anybody have any idea?

My OS version:

Distributor ID: LinuxMint
Description: Linux Mint 17.3 Rosa
Release: 17.3
Codename: rosa

obs: Previous version was 4.7 and it was working pretty well.

Thank you,


Your system is not configured for real time scheduling. You are using JACK2, which refuses to start if realtime scheduling does not work.

Fix your system configuration and it will work again. Alternatively, use the ALSA backend to Ardour. You should fix your system, because Ardour needs RT scheduling no matter which audio/MIDI backend it uses.

I have vs 4.6.0, as packaged Sarah’s Software Manager. Took a while to deduce it would load correctly (without errors) only in superuser mode after entering ulimit -l unlimited. Maybe some of you lgeeks can tall me why this is so? Now to figure out how to get some stuff (synths, sounds . . . ) or quit feeling irretrievably stupid. (Sarah’s Software Manager tries to protect us novices from our ignorance but somehow they missed that one.)

@DickyA: you should never run Ardour as root. If it won’t run without being root, your system is not configured correctly (the link is still relevant and should be read).

Thank you for your reply. I am able to set ulimit -l unlimited while in superuser mode. Then ulimit -l returns unlimited. Log out of superuser and ulimit -l returns 64. That is not good enough to load Ardour4 without many complaints. There does not seem to be a way to retain unlimited in user mode. 64 seems to be tops. I have no inkling about how that situation might be configured away. I suspect it is a feature of Sarah (Mint 18). Or maybe of my computer Dell Optiplex 740 with 6 GB memory and slightly more than that of swap. Maybe you will hear more about it as Sarah gets popular - your vs 4.6.0 is very easy for dummies like me to install from Sarah’s Software Manager (easy, like in Windows).

P.S. Dunno what link you refer to, which you suggest I should read.

The one in my comment directly above yours:


The link in paul’s first response to you. Explains how to set up your system to fix exactly this issue.


The problem is RR/5 being used as realtime priority. jack-process threads use the configured value and the 5 below it, which results in jack trying to create a thread a invalid priority “0”.

New qjackctl (0.4.0 or later) does no longer allow one to configure 5 or less and jack’s default is 50 (at least jackdbus, don’t know about others).

@x42: as usual, thanks for noticing the details!

I just had this problem too. It would be really good if the RT priority problem was included in the error message - as it stands, the error message just looks like a permissions problem, and so it’s impossible to fix without searching for the error on the console.

That’s tricky. The issue is actually in libjack. Ardour asks JACK to create process-threads and JACK fails to deliver… The error message that you see in the terminal is generated by libjack.

But you do have a point, Ardour could show a “best guess” in the popup dialog.

On Linux Fedora 29 I just disabled realtime in qjackctl, now I can create sessions as normal user. (Ardour 5.12.0, jack-audio-connection-kit-1.9.12-6, qjackctl-0.5.5-2)

That means your computer is not set up correctly and you are subject to dropouts/xruns like that.

You need to enable realtime permissions for the user:

If however dropouts will never be a concern for you, then you may not need to worry about it, but if youa re dealing with recording at all you REALLY should get realtime permissions set up correctly.

thanks, yeah, you’re right of course. I was just sharing this quick-fix method, dropouts are currently not a problem for me - just recording some speech.

Ardour’s error message when it fails to create a session is really very misleading, this should be addressed.

by the way, networking causes dropouts on my Fedora 29 - so I recommend disabling all networking. there’s a GUI switch in my task bar / panel to do so. maybe jackd with realtime would fix this, but I haven’t investigated (yet).

Ardour asks jack for realtime threads and will fail to start if JACK can’t provide rt processing.
Apparently fedora hacked around this :frowning:

Most likely it will. Nobody should run a DAW w/o realtime scheduing,