Ardour 5.5 error in UbuntuStudio 16.04

I’m running UbuntuStudio on a Mac (no Mac OS - only Ubuntu). I have Ardour 4.0 from UbuntuStudio. I was running Ardour5.4. Today I installed Ardour5.5. I found that I could successfully open sessions created in Ardour5.4. However, if I close a session then try to reopen another previously created session I get an error message stating: “Session did not load successfully: Cannot configure audio/midi engine with session parameters.” Some sessions will open successfully and some will not. There is no correlation with number of tracks, since some sessions with one track will open and others won’t. The presence of the monitor does not make a difference. I created a new session today with a monitor and VCAs (no audio/midi tracks) and it reopened successfully. I did find that, if I close Ardour then reopen it, I can successfully open any session. Suggestions?

I’m pretty sure this is a bug. I’ve been trying to figure out why I can usually open only one session in Ardour before I get the error message: “Session did not load successfully: Cannot configure audio/midi engine with session parameters.” I tried setting the sample format to 24bit, the same as the wave file I imported, but that did not help. I tried creating a new session in Ardour 5.5; that did not work. I even created a session with no tracks, but that would not reopen either. I don’t think that I changed any of the other default parameters, except to always open the monitor. This session had no tracks, no plugins. It was only the Master Bus. I know that I can just close and restart Ardour, but that seems like a waste of time, especially since Ardour 5.4 worked fine, and 5.5 works fine on my Mac. Is it an Ubuntu Studio problem? Should I be using JACK instead of ALSA (though I tried setting JACK as the audio/midi device and it did not seem to help). Thanks!

I had this happen yesterday with Ardour 4.7. It happend when I opened and closed a couple of sessions without shutting Ardour down. I think it’s an error in the initilization of Ardour, it’s state does somehow not reset properly between loading sessions. Shutting down Ardour of course gets rid of the problem.

Thanks @mhartzel for letting me know. It seems, in my case, to have something to do with creating a session with the monitor open, though I’m not sure. Anyway, I’ll just shut down Ardour between sessions.

I found two sessions that always makes the problem appear. I wrote a bug report here:

@mhartzel would it be beneficial for me to send in sessions that make the problem appear?

I’m not sure. Can you always reproduce the problem with your sessions and can you provide step by step instructions on how to always get the problem to appear ? If yes, then I think it would be helpful to add links to your session also. It would help to check if the cause of the problem is the same with your session or a different one :slight_smile:

@mhartzel I actually have Ardour on Ubuntu Studio 16.04 and Mac OS Sierra (two different physical computers). I copied the session from Linux to Mac, and found the error easy to reproduce. How do I go about sending in the session? Also, do you know if Ardour has a problem when the app is on one physical hard drive and the sessions are stored in another physical hard drive. I understand that DAWs in general work better when the session is not on the same drive as the drive with Ardour and the operating system, which is why I decided to split things up. Thanks.

If you want to have the session available to developers, then you first need to zip it and store it to the cloud (Dropbox, Google drive etc), Then you need to create a login in the bug tracker here:

Then find the bug report I wrote:

add a note to the bug report, fill in your findings and most importantly specify the steps to reproduce the bug. Also add the link to your session in the cloud.

About hard disks and multitrack audio: Ardour does not care if the session is on another drive or not as long as the drive is fast enough. If you use rotating disks, then it is better to have a separate disk for audio. If you use SSD disks, then the disk is fast enough to handle audio and os on the same disk. Exception to this is if Ardour is making a mission critical recording (for example a live performance) then I would record to a separate SSD disk if possible.

I have used Ardour for my personal music projects (4 - 16 tracks, recorded one by one) for a couple of years now and I have the OS (Linux) and Ardour on the same SSD drive where I also record to. I use a big period size (1024) and I don’t have xruns or hard disk related problems ever. SSD disks can die suddendly, so I backup my music after each session to a rotating magnetic disk :slight_smile:

Thanks @mhartzel. This will be my task for the weekend.