Ardour 5.12.0-1kxstudio2v5 and Ardour 6.5 demo version exit while startup on Ubuntu 18.04

Ardour 5.12.0-1kxstudio2v5 and Ardour 6.5 demo version exit while startup on Ubuntu 18.04.

First installed version 5.12 from orginal Unbuntu repo worked fine. Then I installed kxstudio repos and tried to install newest Ardour (in this repo) and Zyn-Fusion. Somewhere in this time Ardour stopped work. It shows session setup windows, then audio/midi setup and then blank gray square that is visible for ca. 30sek and app exits. Any audio/midi setup gives same result.

I had LMMS with Zynaddsubfx plugins installed before. Suspecting them, I purged both with no result.
Tried to install Ardour 6.5 demo version with same result.

Every audio app works fine with both jack or pulseaudio. Usb midi controller works well.
Another thing is, that I’m not sure what proaudio apps, updates and mods to OS I installed in the meantime eg. because of Ubuntu Studio installer trying and so on. I’m completely new in Linux audio so tried these and those…

Debug: https://drive.google.com/file/d/1NVdb3WBTla96t8KiuTiO1ii2RKJx0Cmo/view

What may I do now? I’m not feeling lucky on such problems. Las time I tried Linux audio ended with my gnome broken and OS reinstallation.

From the backtrace, looks like it might be this known Ubuntu bug: https://bugs.launchpad.net/ubuntu/+source/csound/+bug/1754944

Does SOLVED ERROR at start in 18.10 help?

2 Likes

Yes - you are right.
Mentioned solution worked - tested pulseaudio and Jack right after trying “sudo dpkg -P csladspa”.
Thank you very much. Didn’t imagine such fast solution :slight_smile: