Ardour 4.7 window size weirdness


I use Ardour 4.7 on Ubuntu Studio 15.10 on a 13" laptop with a max screen resolution of 1366x768, which is OK under normal circumstances. Recently I noticed that Ardour windows are slightly larger than my screen, and I cannot get it to “maximise”. Both minimise and close buttons work, but the maximise window button is unresponsive. I can resize the Ardour window somewhat by grabbing the corners and dragging it smaller, but the smallest I can make the Ardour window is 1147x770. This fits into the max width of my screen, but it is still “taller” than my screen. Does anybody else have this issue?

Jan Henkins

I have the same problem, since about 1.5 months. I use a laptop with your identical resolution.
I use to compile the development version from git about once a week.

I resolved partially by scaling to a smaller font in ardour (i’d prefer not to do it, though).

Hi, I know there has been some months now in this thread, but since it got no definitive answer, I should say I have started having the same issue. One day it was fine, the other Ardour started having this much-bigger-than-my-screen size, and I have no idea how to fix it.
And this pretty much kills my workflow completely, since there are unreachable parts of the program’s interface.
Ardour’s FAQ answers “scale down font size”, but this is not enough to solve it, and let’s be frank it’s not even related to the problem. Font size was (and still is) working just fine on my screen.

Any news on this issue?

Thank you so much, Ardour is amazing.

I’m using Ardour 4.7 and 5.5 with a laptop that has 1366 x 768 display size and I have no problems. I can resize Ardour windows to fit the screen.

Maybe it has something to do with the window manager / desktop you use, I use Gentoo Linux and Fluxbox window manager.

By the way what os are you using and have you tried this with Ardour 5.5 ?

Maybe the Preference Tab is responsible? Try to Detach and hide it.

thanks for the quick responses!

mhartzel, Im using kxStudio, and Ardour 5.5.0. Thing were working fine for me too, until this afternoon!

x42, the Pref Tab is responsive, yes. On the top screen (1440x900), it fits snugly when I detach and maximize it. On the bottom screen (1366x768) it doesnt, it bleeds into the top one! And it makes no difference to the editor when I hide it… The mixer seems to respect screen boundaries though…

it worked!

After I detached the Pref Tab, I restarted Ardour and things started working again!

Thank you both, specially x42!

I had exactly the same issue running Ardour 5.12 on Ubuntu Studio 18.04 (xfce4 4.12). Detaching Preferences Tab and restarting solved the problem. A big THANK YOU, people!

Same problem on Ubuntu Studio 19.10, Ardour 5.12.0 with both xfwm4 and compiz window managers, also solved by detaching preferences tab, and made no visible difference to anything displayed! Many thanks!

How large (in pixels) is your screen? Are you testing Ardour from or from a Ubuntu repository?

It’s a 1366x768, 15.6 inch laptop screen. Ardour 5 came pre-installed with Ubuntu 19.10, so if pushed I’d make a guess that it was from a repository. Wouldn’t be able to back that up rn though.
The problem has also been reappearing since it appeared to be fixed, although it seems to be less severe. It’ll cover the top half of my panel (which is the bottom of the screen) but if I right click the window header, select resize and move the cursor across the bottom of the window, it snaps it back to the right place. How long that lasts for varies, but it always seems to revert after I minimise Ardour.