Ardour 4.6 Crash

Hello all.

So I just (finally) updated to Ardour 4.6.0 (from the website here of course) and have encountered some unpleasant teething issues.

Heres the story: Recorded a load of audio tracks - started mixing. The first issue came whilst altering a plugin parameter (calf Gate threshold I think). The DSP load stayed low (around 20%) but the audio went crazy - skipping, buzzing and all kinds of unspeakableness that made me worry for the safety of my hardware. The GUI become unresponsive, the playhead was stationary but the savage audio torturing continued. I couldnt get out of it so I went for a hard shut down.

Anyway, reboot - ardour recovers from crash - the world is normal again. For a while…
Next time it happens (about 20 minutes later) I wasnt doing anything with any plugin parameters (I dont think) - the audio does the same thing - farting, buzzing, skipping nastiness. This time ardour did me a solid and committed suicide within about 10 seconds. Following this ardour would not load again until I had rebooted.

Anyway, all this anecdotal waffle isnt a fat lot of use. What I really want to do now is load it from the command line so I can try and catch whatever output there may be to accompany this. Unfortunately (and it pains me to say this) I cant figure out the command to run ardour (tried ardour4, ardour-4.6.0 - and a host of other usual suspects). I even tried dragging and dropping the desktop icon into a terminal but it refuses to load. Can someone give me a nudge in the correct direction please?


The command is probably:


I do not myself use calf plugins, but I have read here in the forums that they are famous for misbehaving and causing all kinds of trouble. You might save yourself from some pain if you can find alternatives to the ones you are using.

I mean:


It seems I have the old version of Ardour on this machine :slight_smile:

Thanks for the replies.

mhartzel - I have heard about issues with Calf plugins, but I have been using them on this OS with ardour 3.5 for a year or two and havent had any issues - I assumed they would continue to work fine with ardour 4 (assuming the way ardour 4 handles plugins is the same as before). Cheers for the heads up on the command.

Paul - I have just tried to run a backtrace with gdb. I managed to induce the behaviour again but this time ardour stubbornly refused to properly crash. The audio went all messed up (sounds kinda like dial up modem noises) then stopped for a while (I mean no sound at all) then there would be a garbled sped up second or two then back to the dial up noises. This kept on for a few minutes so I tried to close ardour. I forced it to quit but when I typed “thread apply all bt” it just returned me to the gdb prompt - no output. Is this because I forced ardour to quit? What is my next step? Do I need to keep going until it dies of “natural causes”? I dont mean to sound meoldramatic but I really am worried it may damage my AD/DA converters in my sound card (not sure if this worry is justified).

Is there any point in posting the messages that were coming up in gdb as it was running? There were some warnings but they may be unrelated.

I should also point at out this point that things arent running smoothly before the nastiness. I am getting a lot of xruns (current count 231 (891) according to qjackctl). A number of these are audible as the standard scratches, clicks, pops etc when running. I am running at 512 frames/periods on a machine running an i5 2500K with 8gig RAM - so performance should not be an issue.

If it matters, I am using Tango studio with an RT Kernel - 3.2.0-4-realtime-amd64 #1 SMP PREEMPT RT Debian 3.2.51-1+tstudio.2 x86_64 GNU/Linux

Whilst writing this I had ardour running in gdb in the background (I am set to all but one core to DSP) and it crippled my machine when not playing (just sitting idle). I was struggling to get the mouse to move, open any other apps, terminal etc. It took a good couple of minutes to kill ardour off to get back to a usable system to finish writing this. My CPU use graph was showing some major activity in the background which ended with ardour ending.

Please let me know what the best way to proceed is. I dont know a lot but I’m happy to what I’m instructed to do.


You cannot damage your converters with malfunctioning software.

The noise you describe sounds moe like a problem with the device driver than anything else.

I find it impossible to help people with issues like on media like a web forum. Find us on IRC, it will be much easier to offer you help.

Your system and jack should be running smoothly before trying to do anything serious with Ardour. It is quite possible that this problem has nothing to do with Ardour. You should first try to find out if it is a software or a hardware problem.

You could test if you get xruns while idling by starting jack with QJackCTL and just letting it sit there running, don’t do anything audio related with you computer. If you still get xruns, then you know there is a problem that prevents Jack from running properly. If Jack has problems, then everything that uses Jack will also have problems. Try also disabling wifi while testing.

Next you could download a known good audio focused distro like KXStudio 14.04. You can install it on a USB stick and boot from it to test Jack and Ardour performance without installing the distro to your hard disk. If the problem goes away then the problem is with Tango Studio software.

On the hardware side: if you use a USB sound card then remove all USB devices from the computer and only leave the sound card, mouse and keyboard connected. A faulty USB device can sabotage all USB commucation. We had this happen a couple of times in the place I work. There is also the possibility that one of your USB connectors has gone bad, connect the audio device to another. Also audio devices should always be connected right to the computers USB connectors, never through a hub.

Also if you have overclocked your computer undo that, it only brings trouble with it. If your computer has USB 3 ports, go to the Bios and disable USB 3 mode and force USB to work in USB 2 mode.

Then you could try to unplug the USB sound card and use Jack with the sound card you have on your motherboard. If this works better, then the problem is with the USB sound device or its cable.

Here is just a couple of things to get you started narrowing down where the problem lies :slight_smile:

Just in case anyone else comes across this thread with a similar issue, heres what I came up with:

The guys on IRC were very helpful. Having tested Ardour without the calf plugins it appears to be running fine and without any significant issues. It seems there have been some changes in ardour that have made using the rather old version of the calf plugins unworkable. I run a fairly old OS that I dont update at all unless it is entirely necessary (I do this to avoid distro update breakage that happens from time to time). Anyway, it seems this is the likely source of the incompatibility issue I now have.

On IRC I was advised that the current Git versions of calf would likely be more stable and usable. Personally, I’m not going to try and build them myself as I checked the dependencies and doubt I can shoe horn them into my current OS without serious work and or breakage of other packages. So for now I’m going to leave the calf plugins alone and see what I can do with other plugins.

I have also noted that some of the INVADA plugins are now causing crashes (although the nice kind where ardour just disappears without abusing my ears en route). There may be others that crop up too as I carry on testing but I’m putting this down to the same as with the calf plugins - OS too old to be using the newer ardour.

Thanks to Paul and the others on IRC for their help. Also thanks to mhartzel for taking the time to offer up some suggestions here.