Ardour 4.1 can't create new session

When I try to create a new session (opensuse 13.2 64 bit) ardour stops. When I start ardour from console I see:

george@linux-0a5j:~> ardour4
WARNING: Your system has a limit for maximum amount of locked memory!
This might cause Ardour to run out of memory before your system runs
out of memory. You can view the memory limit with ‘ulimit -l’, and it
is normally controlled by /etc/security/limits.conf

bind txt domain [gtk2_ardour4] to /usr/share/ardour4/locale
Ardour4.1.0 (built using 4.1 and GCC version 4.8.3 20140627 [gcc-4_8-branch revision 212064])
ardour: [INFO]: Your system is configured to limit Ardour to only 4096 open files
ardour: [INFO]: Loading system configuration file /etc/ardour4/system_config
Loading user configuration file /home/george/.config/ardour4/config
Using SSE optimized routines
ardour: [INFO]: Loading default ui configuration file /etc/ardour4/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/george/.config/ardour4/ui_config
ardour: [INFO]: Loading color file /etc/ardour4/dark.colors
ardour: [INFO]: Loading ui configuration file /etc/ardour4/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /etc/ardour4/clearlooks.rc
Cannot connect to server socket err = Connection refused
Cannot connect to server request channel
jack server is not running or cannot be started
Cannot connect to server socket err = Connection refused
Cannot connect to server request channel
jack server is not running or cannot be started
Found nothing along /home/george/.config/ardour4/templates:/usr/share/ardour4/templates
run dialog
Cannot connect to server socket err = Connection refused
Cannot connect to server request channel
jack server is not running or cannot be started
JACK command line will be: /usr/bin/jackd -t 200 -p 2048 -R -T -d alsa -n 2 -r 48000 -p 1024 -d hw:Live,0 -X raw
Cannot connect to server socket err = Connection refused
Cannot connect to server request channel
jackdmp 1.9.10
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2014 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
Cannot create RT messagebuffer thread: Operation not permitted (1)
Retrying messagebuffer thread without RT scheduling
Messagebuffer not realtime; consider enabling RT scheduling for user
no message buffer overruns
Cannot create RT messagebuffer thread: Operation not permitted (1)
Retrying messagebuffer thread without RT scheduling
Messagebuffer not realtime; consider enabling RT scheduling for user
no message buffer overruns
Cannot create RT messagebuffer thread: Operation not permitted (1)
Retrying messagebuffer thread without RT scheduling
Messagebuffer not realtime; consider enabling RT scheduling for user
no message buffer overruns
JACK server starting in realtime mode with priority 10
self-connect-mode is “Don’t restrict self connect requests”
Cannot lock down 86605722 byte memory area (Cannot allocate memory)
audio_reservation_init
Acquire audio card Audio0
creating alsa driver … hw:Live,0|hw:Live,0|1024|2|48000|0|0|nomon|swmeter|-|32bit
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 2 periods for playback
Cannot create thread res = 1
Cannot use real-time scheduling (RR/10)(1: Operation not permitted)
AcquireSelfRealTime error
INFO: AddressSanitizer ignores mlock/mlockall/munlock/munlockall

==3120== ERROR: AddressSanitizer: alloc-dealloc-mismatch (malloc vs operator delete []) on 0x6004005babf0
#0 0x7f6f166c822a (/usr/lib64/libasan.so.0.0.0+0x1222a)
#1 0x7f6eebfafdb6 (/usr/lib64/ladspa/cmt.so+0x10db6)
0x6004005babf0 is located 0 bytes inside of 8-byte region [0x6004005babf0,0x6004005babf8)
allocated by thread T0 here:
#0 0x7f6f166cbbfa (/usr/lib64/libasan.so.0.0.0+0x15bfa)
#1 0x7f6f0f9e50a9 (/lib64/libc-2.19.so+0x810a9)
==3120== HINT: if you don’t care about these warnings you may set ASAN_OPTIONS=alloc_dealloc_mismatch=0
==3120== ABORTING
Cannot read socket fd = 21 err = Connection reset by peer
Could not read notification result
ClientNotify fails name = ardour notification = 18 val1 = 0 val2 = 0
Cannot write socket fd = 21 err = Broken pipe
CheckRes error
Could not write notification
ClientNotify fails name = ardour notification = 18 val1 = 1 val2 = 0
Cannot write socket fd = 21 err = Broken pipe
CheckRes error
Could not write notification
ClientNotify fails name = ardour notification = 4 val1 = 0 val2 = 0
george@linux-0a5j:~> Unknown error…
terminate called after throwing an instance of ‘Jack::JackTemporaryException’
what():

I would like to know how to start ardour normaly
Thanks

http://jackaudio.org/faq/linux_rt_config.html

Ardour 4 no longer requires the use of JACK, but the system configuration described in that FAQ entry is still necessary for realtime audio work, even without JACK.

see this:

==3120== ERROR: AddressSanitizer: alloc-dealloc-mismatch (malloc vs operator delete []) on 0x6004005babf0
#0 0x7f6f166c822a (/usr/lib64/libasan.so.0.0.0+0x1222a)
#1 0x7f6eebfafdb6 (/usr/lib64/ladspa/cmt.so+0x10db6)
0x6004005babf0 is located 0 bytes inside of 8-byte region [0x6004005babf0,0x6004005babf8)
allocated by thread T0 here:
#0 0x7f6f166cbbfa (/usr/lib64/libasan.so.0.0.0+0x15bfa)
#1 0x7f6f0f9e50a9 (/lib64/libc-2.19.so+0x810a9)
==3120== HINT: if you don’t care about these warnings you may set ASAN_OPTIONS=alloc_dealloc_mismatch=0
==3120== ABORTING

Problem is ladspa-cmt (and ladspa-alienwah at my installation too), so uninstall them, and set Tabbo – Never Install (for disabling automatic installation). This plugins are probably compiled with gcc 5.

I also have the error: “ERROR: JACK: Cannot create thread res = 1” when trying to create a session. Also the notification “session could not be created”.
I’ve checked limits.conf, everything ok. Jackd is running in realtime, but ulimit -r -l tells me this:
ulimit -r -l
real-time priority (-r) 0
max locked memory (kbytes, -l) 64

64kb? I’ve tried the unlock memory option in jackd, nothings helps… Jackd is working, but ardour just stopped, cannot be used :frowning: I need jackd support, because I use ardour to master different soft-synths to one audio file…
Btw. I have 8GB RAM, memory was never a problem with ardour, or any audio software.

Please help.

@moony: your system is not correctly configured. The link you need to read is already posted in this thread.

http://jackaudio.org/faq/linux_rt_config.html

paul: yes you were right. I think I first edited a wrong or obsolete limits.conf, now I’ve inserted following in /etc/security/limits.conf:

@audio - rtprio 99
@audio - memlock 250000
@audio - nice -10

and now Ardour is working and recording again, thank you :slight_smile:

Nice. This works also for my with Ardour 4.7 in Fedora 24.

Once again (I don’t know how many times I need to say this, because I’ve been saying it for 10 years): the nice part of this configuration is unnecessary and has nothing to do with audio applications. Please everyone, stop using it and stop mentioning it.

This post was flagged by the community and is temporarily hidden.