Ardour 3 will not start

hopefully i’ve posted this in the right place. i’ve got a test machine that i decided to put ardour 3 on before upgrading my daw, and for the life of me cannot figure out why i cannot get ardour 3 to start. i’ve tried other beta versions other than 5 as well. ardour 2 runs just fine on the same laptop.

ardour begins to start, asks me to create a new session or open old so i create new (it DOES create the folders in my chosen directory). it then gets as far as the ‘setup editor’ and then disappears.

any idea what i can check? like i said ardour2 runs fine, as does every other music program i run on here.

thanks! if this is in the wrong spot i apologize…just let me know.

os is Fedora 17, 32 bit (i verified i downloaded the correct ardour3 version). test hardware is an old dell d610 laptop.

Actually to be fair the request to not post to the forums stopped showing up during program startup several weeks ago, so it is understandable that vwrecks was not aware of it. That said, everything else you said is right on target.

Unfortunatelly you did post this in the wrong section (currently any topic related to Ardour3 in these forums will be in the wrong section), the developers have been asking many times to not post any issues regarding Ardour3 in the forums yet since it’s still under heavy development and to just go to the Issue Tracker “Mantis” for the meantime so you can help them debug problems there, then when Ardour3 becomes officially released as a final then we can discuss about it on the forums.

Anyway, now that the topic has been fired, did you build Ardour on your own?

I had a similar problem yesterday with yesterdays code, today I updated my SVN tree and rebuilt Ardour3 and opens without issues.

If you did built it yourself, try getting a fresher source, it changes constantly, sometimes even like 5-6 times a day, that is why they ask us not to post on forums and instead report these as bugs in the Issue Tracker (Way above in the tabs of this site). It really helps them better than posting here.


thanks to you both…will head over to the issue tracker…