Ardour 3 SVN compilation error

I dont think this is a bug, but rather a dependency problem. Here is the error:

g++ -o libs/ardour/audioengine.os -c -Woverloaded-virtual -DGTK_NEW_TOOLTIP_API -DPACKAGE=“libardour3” -DLIBSIGC_DISABLE_DEPRECATED -DGLIBMM_EXCEPTIONS_ENABLED -DDATA_DIR="/usr/local/share" -DMODULE_DIR="/usr/local/lib" -DVAMP_DIR="/usr/local/lib/ardour3/vamp" -DCONFIG_DIR="/usr/local/etc" -DLOCALEDIR="/usr/local/share/locale" -DHAVE_JACK_CLIENT_OPEN -DHAVE_JACK_RECOMPUTE_LATENCIES -DHAVE_JACK_RECOMPUTE_LATENCY -DHAVE_JACK_VIDEO_SUPPORT -DHAVE_WORDEXP -DHAVE_SYS_VFS_H -DHAVE_SLV2 -O3 -fomit-frame-pointer -ffast-math -fstrength-reduce -pipe -DARCH_X86 -mmmx -march=i686 -msse -mfpmath=sse -DUSE_XMMINTRIN -DBUILD_SSE_OPTIMIZATIONS -Wall -DWITH_JACK_MIDI -Ilibs -DENABLE_NLS -DHAVE_SLV2 -D_REENTRANT -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -Ilibs -pthread -DUSE_RUBBERBAND -fPIC -I/usr/local/include -Ilibs/pbd -I/usr/include/glib-2.0 -Ilibs/surfaces/control_protocol -Ilibs/midi++2 -Ilibs/glibmm2/glib -Ilibs/sigc++2 -Ilibs/vamp-sdk -I/usr/lib/glib-2.0/include -Ilibs/ardour -Ilibs/taglib/taglib -Ilibs/rubberband -I/usr/include/rasqal -Ilibs/evoral -I/usr/include/libxml2 -Ilibs/evoral/src/libsmf -Ilibs/taglib libs/ardour/
libs/ardour/ In member function ‘bool ARDOUR::AudioEngine::get_sync_offset(ARDOUR::nframes_t&) const’:
libs/ardour/ error: ‘offset’ was not declared in this scope
scons: *** [libs/ardour/audioengine.os] Error 1
scons: building terminated because of errors.
make: *** [build-stamp] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2
debuild: fatal error at line 1334:
dpkg-buildpackage -rfakeroot -D -us -uc failed

Please help me? Thanks in advance.

gee, thanks… And no, I didn’t enable anything else either. Nowhere did I see I should build with ./waf. Anyway, I just started compilation again and it hasn’t produced any more errors.

@tbonedude: please understand that a3 is not ready for testing, not even for test building, by anyone who would choose to post on these forums after encountering the kind of problem you encountered. We have not tried to present it in any other way, and perhaps you’ll forgive our testiness when we run into people who have difficulties like this. I am not sure how we can make it more clear than that for now - its not as if we’ve released a3 in any sense. if you choose to try a3, you’re mostly on your own, though some level of “support” for this kind of thing does happen on IRC, but certainly not here in these forums. I know that I do need to update the build information page to indicate that we use waf, not scons, for building a3.

as it turns out, your build does point to a potential bug in the code, which i’ve just fixed. if you want to keep trying out a3, please join us on IRC.

At this point you shouldn’t be compiling A3 unless you can fix things like this yourself and submit a patch back to fix the issue. A3 is still under heavy development.

In your case your problem comes from not even building A3 with the correct tool. You should be using WAF. You also seem to have tried to enabled something in scons that has no business being enabled on anyone’s machine short of Robin or Paul’s really.