Ardour 3 Slow scrolling/GUI response

Hello there.

Im running Ardour 3.3.1 on Tango Studio (thats an Ubuntu 10.04 derivative). Im suffering with slow scrolling and gui response whenever my project starts to get to a useful number of tracks. I did some googling around and found previous reference to such issues relating to video drivers so I’ve been trying to figure out what the issue is exactly and how to fix it.

I’m using an intel i5 with 8gig Ram and a PCI Maudio soundcard - so system resources shouldnt be an issue.

I was running with the ‘recommended’ NVIDIA driver from the distro but tried updating to to the latest from the NVIDIA site. I’m currently running the 304.88 driver. I need to be using the NVIDIA drivers to allow use of my dual monitor set up (and also the standard distro supplied NVIDIA packages never allow use of Message Signalled Interrupts).

Not sure how to proceed with this now so any help gratefully received.


Hi i’m experiencing the same kind of behaviour, but it seems this more related to the editor than the video card. I believe a new editor window is being developped using cairocanvas, perhaps this will solve this behaviour.

Same issue here, it gets a lot slower than A2

Interesting to see others with similar issues. FWIW I have found it to be worst when I’m trying to scroll across the Mixer window.

My belief about it being related to the video card driver same from reading Seablade and Pauls comments in the thread below:

I wondered if there could be a way of fixing whatever mis-match is going on with the libcairo and NVIDIA driver. I did try setting the ENV variable in a terminal and then running Ardour from the same terminal but no joy. I suspect I was barking up the wrong tree anyway as I would reckon that the ENV variable is set when compiling Ardour from source (? - maybe?).


it is not just nvidia. we recently saw a very experienced ardour user switch his radeon card to something else (possibly just a newer radeon card), and the result was a dramatic improvement in scrolling/zooming performance.

there are bugs in nvidias drivers it causes the same slow drawing when switching between windows and scrolling.

I’m not at my home computer but theres a couple of settings u can try. they fixed the issue for me.

nvidia-settings -a AccelerateTrapezoids=0
nvidia-settings -a InitialPixmapPlacement=0

Try these settings in a terminal and see ifit improves rendering performance.

it took alot of googling, but i found that there were commen complaints about nvidia drivers under linux causing poor 2d rendering in some cases which were not present when using the open source driver. I get the same issues in web pages aswell with poor scrolling speed and also when switching between tabs in my browser taking upto 5 seconds but was fixed to almost instantly changing now when using those 2 settings.

Those settings are not persistant so they need to be set after login in, you could put them in a startup script so that they load it up on boot.

I confirm it’s not just nvidia, my card is an ATI Radeon 4800 and the issue is there with the latest legacy fglrx drivers. They do a slightly better job with A2. Anyone has a workaround for ATI cards?

thats wierd i had an older ati card running 2 monitors until it packed in and i dont remember having performance issues well maybe not as bad as with nvidia…

I cant remember which card it was, ati radion saphire HD something that used the legacy drivers.

So it all seems like a bit of a lottery, unless someone can be specific about what is actually causing the issue. For what it’s worth, I have nvidia and ATI systems, and while, unsurprisingly, A3 runs slower on both machines than A2 did, the most significant issue I’ve noticed is that my ATI system won’t display openGL plugin GUIs (for example, the Harrison Mixbus plugins etc) properly. I’m told this is an issue with my combination of chipset, drivers etc, but oddly, all other GL based applications I’ve tried (including a GL based plugin GUI I made myself as a test) seem to work fine. Reminds me (and not in a good way) of juggling different DirectX versions / drivers etc many years back on a certain other operating system…

@veda_sticks - Those two settings give a BIG improvement for performance on my machine. I’ve only tested very briefly before work this morning but the scrolling seemed to have returned to what I would call normal. I assume I can set those parameters into ~/.nvidia-settings-rc and load that from boot to make the settings persistent instead of using a script?

My level of knowledge is pretty limited but I can follow instructions reasonably well so if there is anything I can do to try and isolate what the problem is then I’d be happy to try. Just let me know what info to provide.

Cheers for the help.

Good that its helped you aswell it may only help some video cards that dont do 2d acceleration well or maybe it effects most but it does seem to be a bug in nvidias settings or something since the open source drivers dont cause the issue.

Im really not sure about scripts etc and have only been suggested by others where i found those settings to add them to a script.

nvidia-settings brings up the gui for setting some basic settings for the nvidia driver, but it seems that you can pass settings to it via the terminal and it doesnt bring up the gui. Though im not sure if you need an x-server loaded for it to work, so it may allow you to load settings on boot up but it might not.

I was thinking of just putting the 2 command line settings as a startup app, but i cant find where you would do that. In ubuntu studio there was a program to add stuff that started up after login but cant find it in av-linux

ok i tried adding those attributes to the ./nividia-settings.rc file and to confirm to how the rest of the attributes looked in the file added 0/ to the begging.

Slow 2d performance when switching between mixer and main track window and when opening up plguins, i had to set the attributes via the commandline and bang, normal good workable performance.

So putting irt in there doesnt seem to apply the setting, there maybe something missing for it to work in the config file like specify a display or something.

whats annoying is that if you go into nvidia settings app and save the current config, the settings you apply via the comandline done get saved into the file.

@veda_sticks - It works for me but you cant just put the settings in the ./nvidia-settings.rc file. For some reason that file just sits there until you actually call those settings up (I’m still trying to figure out why). You can manually call it with “nvidia-settings --load-config-only” which seems to work. I put that into a script and added it to the startup applications list (I’m on a 10.04 derivative so I found it under System > Preferences > Startup Applications) and it seems to work. I tried using ./xinitrc to issue the command but it didnt seem to work.

I was hoping for a tidier solution than just having a script like you originally suggested but appear to have just ended up with the same end result (a script) that takes more effort to create. :wink: Hey ho!

If it helps anyone else to know, I’m using an NVIDIA Geforce 7900GTO card. It has become a bit funky with the newer drivers aside from this particular issue. If I use a driver pre the 190ish series it behaves reasonably (although not with ardour 3) but any newer drivers I get a weird blank screen for a second when I log in. It gives me the password log in window and as soon as I hit enter - black screen for a second, then loads desktop. Then after another 5 seconds or so it gives me blank screen for a second again - then normal. Doesnt do it again until next time I log in. Happens with my Tango Studio set up and my Ubuntu Oneiric (dual booting). I offer this anecdote just as further support showing that the proprietary drivers are being kinda buggy these days.

As I said before, if anyone wants me to try and diagnose anything more - just tell me what to do.


I came to this thread because I experience GUI problems similar to those described here. My computer is a laptop with an i5 processor and a dual optimus card : Intel and nvidia. I usually disable the nvidia card with bumblebee because it heats up the computer, the fan goes noisy etc. I tried to use it with Ardour however, hoping that it would speed up the GUI responsiveness. I’m not sure I could see any difference. This was with the nouveau driver. Would nvidia give better results maybe ? Did anyone compare nouveau with the proprietary driver (and maybe with Intel if you also have an optimus card)? I’m asking about Ardour’s GUI responsiveness of course.

Another question in the same vein: does anyone know if it should make any difference for Ardour whether I have or not a compositing manager (currently I don’t)?

i have read in some cases that having composting enabled can speed up gui performance but ive not tested it knowingly in ardour. Im not really wanting to test since i dont have a full understanding on how to test properly and dont have the time to be going back and forward between configurations. not to mention things just change to fast, alot of the info i find through searching go back to earlier versions of ubuntu.

Ive got a fresh install of KX studio with all the recent updates, theres no xorg.conf.

What i did notice recently is that i tried a different driver this time. normally ive installed the nvidia-173-updates driver, but this time i decided to try the nvidias binary driver in the additional drivers utility. When i load up nvidia-settings it says im using 304 Now that ive got them installed, it says i am using nvidias accelerated graphic driver (304) rather than saying nvidias binary driver when i first loaded up additional drivers

From what i gather, the open source driver seems to work better on some cards.

I dont see the screen blanking as much of an issue if everything else works fine after that


I switched my video card from ATI to NVIDIA (GT610) and saw an improvement in A3 scrolling/zooming, but it’s still too slow. I tried your settings

nvidia-settings -a AccelerateTrapezoids=0
nvidia-settings -a InitialPixmapPlacement=0

but for some reason all windows decorations disappeared! I’m on Ubuntu 12.04, so I have compositing enabled

Ive no idea why windows decorations disapeared, that would mean that the window manager crashed. Did you try reloading the window manager ? and did it just crash again.

i am now using these settings

nvidia-settings -a InitialPixmapPlacement=0 -a GlyphCache=1

Which seems to have the same affect for me, I dont thik acceleratetrapeziod is doing anything noticable. try the above settings and see if it crashes the window manager.

Also what nvidia driver are you using? If you can live without good 3d performance (if you dont play 3d games) then you can just use the open source driver. Nvidias propriatery drivers have been known to be buggy in linux.

Im actually thinking of going back to a newer ATI card, i had an older radeon card which worked great with dual displays but something went wrong and now my system no longer recognises the card. I guess it burnt out or something. So im back to onboard nvidia.

I’m running kx studio 12.04 which im sure has composting enabled, im now running lxde as i prefer the lighter system load. Not as fancy looking but its nice booting into a system that only consumes about 250mb of ram after login.

hi veda, thanks for the answer! I tried to reload the window manager to no effect, I’ll try your new command and report! I’m on ubuntu 12.04 with the latest nvidia drivers, nouveau is not working with unity so no choice for me. Yes I could use a lighter environment but I really love unity I do everything faster with it and don’t want to give up…