Ardour 3 JACK/Monitoring issues

Hi everyone,

I have been trying to set up Ardour 3 and have been running into some issues with configuring. I have previously used versions of Ardour 2 with no problems, and read through the manual for 3, yet am running into problems.

My setup is simple:
Focusrite Scarlett 2i2 USB Interface
Ubuntu Studio 12.10 with self-compiled rt kernel

First, when starting Ardour 3, I tried to set it up my interface, which works perfectly in Ardour 2.8 (my previous version). I use it in duplex for both input and output.

The first time I started Ardour 3, I did so without starting qjackctl, which I normally use with Ardour. In the settings I was unable to select my input and output devices, even after changing the option to USB. I tried continuing anyway and found that for whatever reason Ardour would pick up the input from the interface, yet feed the output to the computer, instead of the interface.

Next, I tried starting qjackctl first and then starting Ardour 3. I was able to get it so that both input and output worked via the interface, but ran into something else:

The monitoring function seems to be “doubled”. When muting a track containing the input from the first channel of the interface, I could still hear the interface, although there was a definite change in the audio – as if the channel was being “monitored twice”.

Anyway, I was hoping someone could point out how to remedy my issues. Thanks.

I suggest look at the QJackCtl connections panel to see what is connected in Jack both internal and external to Ardour. Also recommended is the Ardour reference manual:

I’m having similar issues, except I can’t get it to play through my interface at all. The manual doesn’t really help for interface setup. In fact, that entry is missing when I click on it.


I was able to get things to work properly by restarting my computer. There was a problem with Jack in which it seemed as if the daemon was running twice. You could try killall with jack, or just restart your computer. Maybe that’ll help?