Ardour 3 and Addictive Drums

I am wondering if anyone knows how to get addictive drums working on a MIDI track?
I have a Microkorg I want to use as a MIDI keyboard, or failing that I have a dedicated MIDI keyboard.

Basically I am connecting my Microkorg into my guitar rig 3 interface and then USB to my mac to get the actual audio from my Microkorg, this all works fine.

I have hooked up a MIDI lead from IN and OUT of Microkorg to USB in on macbook…Now I need to know how to use it as a MIDI controller AND, more importantly how to set up Addictive Drums in Ardour 3…pleeeeeeease!

Thank you for reading!

Mark :slight_smile:

You have Addictive Drums as an AudioUnit plugin? I suspect you will be the first person to use it in Ardour. What precisely are you confused about?

I have it installed in Library>Application support. It doesn’t work as a stand alone piece of software. I can get in working in Garageband as an instrument and it opens up fine in Garageband. Sorry I’m a bit rubbish when it comes to MIDI stuff.

So basically I don’t know how to open it in Ardour? I have created a new MIDI track but I can’t find an option anywhere to start it.

So your help would be much appreciated :slight_smile:

Well, when you add a new MIDI track A3 asks also if you want to add an instrument, it shows a list of them to choose it, but if you didn’t do that you can also add it as a normal plugin on the Mixer window, on the Midi track you added clicking above the fader, it brings up a menu where you can choose the plugin by type or creator, also you can double click and a screen will come up where you can type its name and it should show up then select it and add it to the track.

If you can’t find the plugin then there would be probably some kind of compatibility issue but if it is an AU it should be there.

Just tried this but still couldn’t find Addictive Drums. I notice that when Ardour starts up that it does detect Addictive Drums as an AU though? But then the only one in the instruments list is the DSL Apple one. Tried choosing from the mixer window but only the DSL one appears again? :frowning:

Really would love to solve this problem as I really want to use Ardour to make music!

Ardour is almost certainly finding Addictive Drums but decides for some reason to not show it in the instruments list. One thing you could to help the diagnosis of this issue would be to collect the output of Ardour in the Console window (Applications > Utilities > Console) as it starts up.

This is a bug, and as such should be reported and tracked at, not here on the forums.

Cool, thanks man. I’ve just reported it in the bugs section! :slight_smile:

fwiw, I use Addictive Drums on Linux, but not as a plugin. I run the plugin as a standalone program and then route the midi data out from ardour into AD and the audio from AD into a bus or track in Ardour. I can’t tell you how to do this on Mac, but I’m sure a simple, jack-friendly plugin host exists… (perhaps pedalboard or AU lab?) The one caveat with this approach is that you can’t drag-and-drop midi loops from AD into Ardour, if that’s something you’re keen to do. XLN happily provides the midi files for all of their loops, though, so you can load them in an Ardour session easily.
Hope this helps, I know it’s not as clean and easy as the “right” way will be, but at least you can make sound this way until all bugs are squashed and features enabled.
(and I keep hoping that someday XLN will make a native linuxVST version…)