Ardour 3.5 in Jessie

Hello !

I connected a midi keyboard via usb in Ardor 3.5 on Debian Jessie

I have configured the kernel for low latency

Jack server is running fine, but in the connections I do not see MIDI to Ardor

Any suggestion?

Thanks !

Nobody should be using Ardour 3.5 for anything. We are at version 5.10 now.

Possibly your distribution calls newer versions ardour5. Whatever way works best for you, get a newer version before doing anything else.

@A350 If you want to connect usb midi keyboard to anything using jack2 in Debian Jessie, you will need to install a small helper program called a2jmidid. So in terminal: sudo apt-get install a2jmidid . After you start jack (or Ardour with jack backend), open terminal and type a2jmidid -e and hit Enter. Your keyboard should appear in the connections as “a2j:(your_keyboard_ID)”. Don’t close terminal with a2jmidid command because you will terminate the connection.
And of course, you should upgrade to Ardour 5.10 (Ardour 3.5 was quite unstable in MIDI department as far as I can remember, you may lose your song…) , but procedure for connecting midi keyboard remains the same.

what vasakq said: (or use a distro which does this setup for your e.g. KXStudio or AVLinux and which also ship a recent version 5.10)

PS. Debian/stable (9.0 aka stretch) does ship Ardour 5.5 (note the package name changed to just “ardour”)

Thanks for the tips…


a2jmidid -e
JACK MIDI <-> ALSA sequencer MIDI bridge, version 8 (7383d268c4bfe85df9f10df6351677659211d1ca) built on Thu Jan 1 00:00:00 1970
Copyright 2006,2007 Dmitry S. Baikov
Copyright 2007,2008,2009,2011,2012 Nedko Arnaudov

Bridge starting…
Using JACK server ‘default’
Hardware ports will be exported.
Bridge started
Press ctrl-c to stop the bridge
port created: Midi Through [14] (capture): Midi Through Port-0
port created: Midi Through [14] (playback): Midi Through Port-0
ERROR: a2j_alsa_connect_from: can’t subscribe to 20:0 - Resource temporarily unavailable
port skipped: USB2MIDI [20] (capture): USB2MIDI MIDI 1
ERROR: a2j_port_create: snd_seq_connect_to() for 20:0 failed with error -11
port skipped: USB2MIDI [20] (playback): USB2MIDI MIDI 1

this is the error with a2jmidid -e

@A350 Before you start jack make sure MIDI System is set to “none”. That is the last option in Ardour Audio/MIDI setup window, or in qjackctl > Setup window > MIDI Driver should also be set to “none” (somewhere in the upper right region of the window).
I’m sorry for a late response, I was out of the town for a couple of days…

The simplest approach is to just not use JACK at all. Use the ALSA backend for Ardour, and all your MIDI ports will show up without any extra work on your part.

If for some reason you actually need JACK, obviously this is not an option, but for a lot of people, JACK doesn’t actually serve any useful purpose.

Well, After testing and testing, i have come to the conclusion that this midi / usb cable> on my old keyboard midi>
does not convert the midi signal into audio. I will try these days with a usb / usb keyboard and see if it works.