Ardour 3.5 during playback and render briefly changes a volume

It’s a very odd issue. It happens very occasionally and not at the same time and place. But if I render (or playback) my edited project, Ardour briefly change the volume of track (or master?), hard to say. It’s louder for a very short moment. It happens during the render too. I rendered a project several times and it happened in different moments of wav file. It is very brief issue, a 100 miliseconds, or something like that. But I can’t use the file. Do you know what to do?


I would suspect a misbehaving plugin somewhere along the line, perhaps try removing various plugins and exporting again.

What plugins do you mean? I used pan and volume automation only. No additional plugin is inserted to any track. I will try to upload a sample of the mistake.

...I used pan and volume automation...
Could this be related to the problem?


What version of Ardour are you using? If you aren’t using any plugins but are using automation there were some known automation drawing bugs that were fixed in the latest Ardour 3.5.357 release. If you make the automation tracks visible do you see any unwanted spikes or deviations in the automation curves?

I have the newest version of Ardour. Yes, I am using automation, but without automation, I can’t use it. There is no unwanted curve change in automation, i checked it. It seems OK. As I said before, it is quite random. That sound deviation is not always at the same place. It could be bug, but I cannot describe it better, it is random.

Pan and volume automation could very well be the problem. ive had issues with this before when ive not done it properly . usually when ive only recorded automation for parts of the project and used the wrong mode.

i cant remember exactly but i havnt had much luck recording automation on sections of a project, usually i just do it for the whole song, otherrwise i end up with some wierd behaviour

I don’t think I’ve ever seen an automation system that doesn’t do something a bit odd sometimes - automation is difficult, and I speak as a verteran of a well known UK console manufacturer whose products virtually invented console automation, and I can tell you from experience that it is much more complex than it might seem (to put it mildly)…

I will check the automation, maybe some change helps, but what else could I do? Maybe somewbere I didn’t use an automation for a whole project. When I get back home, I will check it all and post a sample here.

Here is the sample of the mistake. You hear a very short change of volume at the end of the sample. Hope someone helps. I tried all the automations use for a whole track (or tracks). From the beginning till the end of an event. Must say, it happens not very much. But I have 40mins long track and that’s why it is very hard to find.

correction: I made the sample again. The mistake is in the middle of that sample (0:02)

Noone helps? I really don’t know what to do. I think it must be a software bug, but I am unable to replicate that bug, because it is never at the same place. But I figured out how to find a number of “dropouts” in rendered file and potencially remove them. I rendered it twice and both files opened in audacity and invert phase of second file and rendered it again. In that file, I had dropouts only and nothing else. I found out the number of dropouts is quite big (yes, dropouts were from both rendered files, but still big). Some dropouts were unable to listen, but still were there. This technique can remove dropouts from files, but it is quite silly, isn’t it? I like Ardour, it’s a good soft, but if it remains, I will be forced to quit using Ardour and support it.


I think the problem is that you seem to have been able to do something noone else has, so noone has a whole lot of advice they can give you at this time, other than to start from scratch and see if it repeats.


I must say that it is quite strange that noone has simillar problem. What should I do? Reinstall Linux completely? I did it 3 years ago, maybe it helps generally.

it is very unlikely that reinstalling linux will do anything to fix this issue.

I think it won’t help too. But I don’t know what to do. I tried different sampling rate, different project, same problem. Last thing I plan to try is complete remove all automation and rener it again. I will do it and post my results…

So, I did it and it is confirmed. It’s automation related. I deleted all automations and no error and there are no errors in audio. Have you got any ideas?


If you have not already, create a SMALL project to reproduce the issue if you can. Then create a Mantis issue and attach the project along with an example render that demonstrates the issue. It will at least allow others to see if they can reproduce the issue with your session or not.