Ardour 3.5.357 released

Ardour 3.5.357 is a CRITICAL bug fix release. ALL USERS ARE RECOMMENDED TO UPGRADE. It includes an absolutely vital fix for a bug that could lead to audio files going missing from the session file (though not from disk). Stem export finally works reliably, and touch sensing with Mackie Control devices allows correct recording of automation from the faders of devices like the SSL Nucleus.

Another important change that some users will notice: when using the mouse to click to add automation control points, Ardour now just adds a new point where the user clicked, rather than attempting to preserve the line shape. Control/Command-click will use the old behaviour. This change followed some mailing list discussion in which it became clear that although the behaviour now accessed via Ctrl/Cmd-click is occasionally useful, it is mostly wrong.

As usual you can download it from the usual place, and as usual subscribers get this update without cost. Thanks to everyone for their support (and encouragement).

Once again, the OS X release situation has still not improved, though a demo 64 bit copy of this version is available (fully featured except that is has does no saving or restoring of plugin settings, and no plugin presets).

Fixes & Changes

  • Fix major error with file naming that could lead to sources no longer be listed in the session file
  • Fix crash during stem exports
  • Fix crash when removing synth from a MIDI track with bypassed plugins
  • Fix routing display for mono synths and midi tracks without instruments
  • Properly support touch-sensing on Mackie Control devices
  • Correct automation recording from Mackie Control devices
  • Adding automation control points with the mouse now defaults to just adding the point without "guards" to retain line shape. Use Ctrl/Cmd-click to get the previous behaviour, which is occasionally useful but generally wrong.
  • Fix meter(s) when mixer-strip is switched to AuxSend
  • Fix a timing problem with Mackie Control device discovery that could lead to the device not being present as Ardour starts up
  • Expand directories searched for native Linux VST plugins
  • Update LV2 event extension support
  • Change use of word "Direction" to "Azimuth" for VBAP panner
  • Fix issues with panners when a splitting plugin is added
  • fix panner issues with monitor section
  • correct the default key binding for "previous snap choice" (3)


Robin Gareus, Paul Davis


Many thanks to Damien Delpiroux for his help in debugging issues with filenames and missing sources, along with the rest of the crowd on #ardour for their testing help.

Oh, the stem exports! Happy, happy, joy joy!!! Much appreciated! Nice work, everyone!

Thank you guys!

Thanks for your work !
Could you update the OSX link on the download page ?
It seems to be stuck on the 3.5.308 version.
Many thanks again

I actually lost an audio file (trac) after this upgrade for the first time ever.I’m just glad the trac wasn’t very good or important.I sincerly appreciate all the hard work the folks at Ardour are doing nonetheless.

same here… ever since the upgrade I’m losing audio files and they’re not on the hard disk.
I’m on Arch64 and have tried both binary and the arch repo and the same thing happens.

Is this the best place to report this?

I must say though that every release workflow becomes easier. This app is awesome. Thanx guys.

Yeah, that’s the first thing I did :wink:
I downgraded to the version of Ardour I was using too, working perfectly now.

Sadly, no.
But it’s pretty consistent here, it happens everyday in ALL my projects.
Right now I’m opening a song I was working on yesterday and two more files missing. Funny thing is, in order to check if I’m really losing something, what I did is create a really loud noise wav file and when the program complains about a missing file I copy that into the interchange/…/audiofiles folder, so I know when I hear the noise.
For now, I never heard the noise, and although I keep getting those messages, strangely I don’t think I’m losing any instruments.
It makes me nervous anyway, you can imagine.

What I can tell you is that I don’t have any “new project”. All the projects I open were created with older version of Ardour3 (I think it was a couple of versions back), which was extremily reliable version for me, no problems at all.

Thank you, Paul.

Ok. The sooner I speak…
Now I hear the noise, I checked and I lost a vocals take. I’m very nervous now about losing more things. :frowning:

Another update, I re-recorded that lost vocal I just lost (it was just one line).
Closed Ardour, opened it and another complain. I did the same, and this time the noise came from a hammond lick. Lost too.
So it seems develop, cause that hammond was there last time I checked (ten minutes ago). It seemes everytime you save something’s wrong, some index or something.

If it’s useful to you I can send you my project file (the .ardour file). If you send me your contact, mail or something I can send it to you

I think I gained some new insight into this bug overnight. Will be working on it today, in between meetings.

psst: I really hope you are backing up!

this i wierd, i have seen the forum comments of several people loosing audio files. ive not experienced this yet but i am not working with alot of tracks or doing any layering.


That is the problem, noone is losing them consistently, and there is no recipe to replicate the problem so it becomes very hard to troubleshoot or fix.


I’ve never experienced file loss before, but after upgrading to the last version about a week ago, I’m losing audio files day by day.


Other than that, fantastic app that only gets better and better, but this bug is really worrying.

psst: if this is happening to you every day, do you have a “recipe” ?

Already discussed this on IRC but I’ve lost even more audio files. Is there a mantis report for this?

@christophski: not that i am aware of. but to fix this, we really need a recipe to repeat it.

Now file loss happened here, too. The lost file is a MIDI-file. Maybe this helps somehow in debugging…