Ardour 3.5.308 released

    Continuing on with our cycle of monthly releases, 3.5.308 contains a

pile of bug fixes and several very useful new features. Almost entirely the
single-handed work of Robin Gareus, you will find significant changes with
panning, auditioning and the very striking addition of explicitly-displayed
signal router in the mixer strips.

As usual you can download it from the usual
, and as usual subscribers get this update without
cost. Thanks to everyone for their support (and encouragement).

    Once again, the OS X release situation has still not improved, though
    a demo 64 bit copy of this version is available (fully featured except that is has
    does no saving or restoring of plugin settings, and no plugin presets).

Additions &amp Changes

  • add visualization of signal flow within tracks and busses
  • Various improvements to panning
    • add stereo-balance panner
    • right click on panner to select a different (compatible) paner
    • major overhaul to VBAP panner so that it works
    • panner GUI tweaks
    • Sends now have their own panner
    • Send panner may be (un)linked with the main panner via the context menu of the send. If linked, the send's panning follows the main panner.
  • Various improvements to import and auditioning
    • Add MIDI auditioning (using Ardour's builtin "reasonableSynth")
    • Consider all tracks in a MIDI (SMF) file
    • allow auditioning via the monitor section to work (and make it the default when using a monitor section)
    • add a seek/locate slider to the import auditioner
    • auditioning now uses sample rate conversion when necessary, so that auditioned files are always played back at the correct pitch/speed

>Fixes and Improvements

  • do not lock audio to video when extracting only the audio from a video file
  • re-enable export file tagging and fix export format dialog inconsistency
  • fix audio cross-talk between tracks that occured when using 1in/2out tracks.
  • fix the "replicate missing channels from regions" option
  • fix text "bleeding" in various buttons
  • provide some level of compatibility with aubio 0.4. Ardour should still be built using aubio 3.2.
  • improve rendering of faders
  • add M-Audio 2496 to the list of devices recognized to have a "control app"
  • fix behaviour of plugin parameter sliders for ranges [0..]
  • new MIDNAM files for Moog MF-104M and MF-108M
  • add support for MIDNAM controller labels
  • document MIDNAM controller values for Moog Minitaur
  • fix display isues with editor mixer strip
  • fix 32 bit export
  • fix crash when adding processors which change overall track I/O configuration
  • fix deadlock when removing monitor section
  • ignore additional channels during AFL/PFL (if the track/bus has more channels than the monitor section, ignore the additional channels)
  • fix output metering for Sends
  • new MIDI binding map for Roland V-Studio 20
  • new very basic MIDI binding map for M-Audio Oxygen-25
  • fix display of pan automation and MIDI fader automation
  • working support for VST "timeinfo" delivery to plugins (Windows VST and Linux VST)
  • fix crash when instrument plugins fail to load
  • fix potential for duplicate Send IDs
  • auto connect preferences now respected for MIDI tracks
  • use all outputs of VST plugins, not just the input count


Robin Gareus, Nils Philippsen, David Robillard, Paul Davis. But really, Robin Gareus.

Inspiration & Designers

As usual, many thanks to Chris Goddard, Axel Müller, Jörn Nettingsmeier and Gabriel Nordeborn for their participation in the design and testing of many of the new GUI and backend aspects of this release.

Translation Updates

  • Russian translation updated (Alexandre Prokoudine)

Great release, thanks as always!

I use ubuntustudio 12.04 + kxstudio.

Tried ardour 3.5.147 (or whatever the number was) and it didn’t export to audio. Tried ogg and wav as suggested in the IRC channel.

Tried ardour 3.5.308 and it does start exporting and even creates a file but takes forever. Even on small project. Like a few kilobytes after 10 minutes, and slooooowly growing.

If there’s a way to make a more useful report, please tell.

Thanks for a great piece of software!

If there's a way to make a more useful report, please tell.
At the top of the page... "Bug Tracker"


I’ve already created a bug ticket in mantis. The “stem” export does not work and the region/range export has some trouble in qualitiy.
The normal file/session export works so far. I hope the devs can find time for this next time. The stem export is a very cool feature!

@LucasG: This may be a JACK2 issue - unfortunately we have the unhappy situation where JACK2 is installed by Ubuntu based distros by default, however JACK1 and JACK2 are both called ‘jackd’ so users most likely won’t be aware of which they have without further investigation (or even be aware that there is any difference) - or they might logically assume that JACK2 is an incremental improvement over JACK1, which unfortunately it now isn’t, as JACK1 is actually a better choice, especially after the recent updates. Even more unfortunately it seems there exists no reliably clean method to compile and install JACK1 once JACK2 is deployed, without potentially stopping both from working - especially on Ubuntu systems (or unless you have prior experience of this and can untangle the resulting mess).

@linuxdsp: I’m just wondering. I checked the stem export on Ubuntu Studio and KXStudio. Both are Ubuntu based. I tested with JACK1 and JACK2 installed from the repo. Have you got some experience/known problems uninstalling JACK2 and installing JACK1? For now in all cases I had a pretty good working jack. Some advices how to test it better?

@eddrog: From personal experience (very recently installing Ubuntu 12.04 LTS) my problems with JACK1 / JACK2 happened when I compiled / installed JACK1 from source - currently the only way to get the most up to date version - after installing / removing JACK2 - the Ubuntu default - previously installed via synaptic. I’ve also had problems with exporting sessions (randomly but on a reasonably regular basis since early Ardour2 about four, five maybe more years ago) - it may be that when it happens it does so for different reasons, and my suspicion is that it is more JACK related than Ardour, as I don’t think I’ve seen any problems now with JACK1 - but my main concern would be that to a new user (or one not familiar with Ardour / JACK, it appears as a bug in Ardour, and quite a serious one if it prevents exporting the session - and also one which they wouldn’t be aware of until they did export their work) that wouldn’t inspire my confidence if it happened to me.
If there is an issue with JACK1 vs JACK2 and sesion export - it would be great if it could be fixed (as a matter of urgency - as it renders all other ‘improvements’ pretty much void if you can’t actually export the finished work) - or if its not within the Ardour dev’s control (and I suspect it is not) then it needs to be much more discoverable and not a nasty surprise waiting to strike when a project is finished…

there might be an error in the download page, I downloaded and built the source code, and is says it’s version 3.5.284…

there is no “if” about export and jack2. There was a bug in jack2. Robin Gareus provided a fix over a month ago. There has been no new release yet (I’m not even sure if his fix was committed).

@paul: I just installed JACK 0.124.1 and made some tests. I get the same results. Stem export is crashing and region/range export works, but if fade-off is supplied the exported sound is very strage in the fading part! Perhaps I’m doing something wrong but I don’t know what :-))

Thanks all!

So, from my newbie point of view, I think I’ll wait from the external (from jack2) fix. (Purging jack2 to reliably put jack1 in its place looks too tricky.)
Meanwhile, I’ll keep using timemachine to record the output, as that’s enough for my purposes.

It’s good to know I can report bugs more usefully, too. Thanks, @linuxdsp!

Thanks for letting me pay (a small amount, but it does add up it seems) towards this software, @paul and all involved. Really appreciate it!

Not Jack1/2 related, export takes forever…

stem export is crashing on me as well, but only on some projects

@vervelover: oh I’m not alone :-)) What is a good or bad project? I just want to reproduce the behaviour for beeing able to address the bug correct.

why not try kx studio and not ubuntu studio with kx studio repos ontop. I only had export issues once with kx studio and it was a bug in the alsa jack bridge, if i stopped the alsa jack bridge. Export would work fine. that has now been fixed.

kx studio is based on ubuntu, however using the kx studio iso instead of adding kx studio onto of ubuntu studio just works better.

@veda_sticks: oh I see. Pas de probleme. I just had trouble to install kxstudio on my new efi based machine (multi boot) and I’m not a fan of KDE. Ok I’ll try it.

actually i just tried to do a stem export and ardour just quit

@veda_sticks: with KXStudio? If so - then its a bug!?

i’ve just built ardour from source downloaded from
it appears to run just fine, but, to my surprise, the “About” tab from Help menu says: Ardour 3.5.284 (built from revision 3.5-284-g8b71e40)
shouldn’t it be 3.5.308?