Ardour 3.0 alpha 3 released

Another day, another alpha release. And yes, the URLs do not end in ".bz2" anymore. See below for why ...

Changes since alpha 2

  • OSC control now included
  • MIDI binding maps now included (and usable)
  • Package now has an installer, and a README file.
    The installer will put the package into /opt and will attempt to put a link to it on your desktop. The uninstall script (also placed in /opt will remove both the package and the desktop link.
  • name changed to 3.0alpha3

Are you serious? WOW you guys are really working hard here! I really apreciate what you are doing with this release, it is really great!. I’ve been working with alpha 2 today, and works really fine in Ubuntu 10.10 with lastest jack version. I have few minor problems that I will report via mantis or IRC tomorrow, mainly with Calf-git plugins and C* Plate2x2

I’ve been working with 3-alpha-2 for the last couple of days. Thus far, it has behaved more reliably than 2.8.11. It is an absolute joy to use – immediately evident is the amount of work that’s gone into making it straightforward and intuitive. Projects like these are what make the interminable wrestling match with broken-open-source ultimately worthwhile.

Wow, the dream is almost here. I say almost because I expect there will be a few bugs but I’m using Ardour 3 for the first time. This is a joy. I have lots of MIDI hardware and over the last few weeks I’ve had nightmare after nightmare on OSX. The DAWs are all a disaster and hell to use. Now I can move more of my operation on Linux. Macbook is just for hosting reverb plugins now.

I have Pianoteq which is a fantastic software instrument and comes in Linux version. It’s definitely worth checking that out for use with Ardour 3.

I can’t figure out how to use this “installer” (this is the 32-bit alpha listed above, file is 41,541,305 bytes long). I tried setting it executable and running it (no dice), and tried untarring it but got the following error:

tar xvf Ardour_32bit-3.0alpha3_9210-dbg.tar

tar: Unexpected EOF in archive
tar: rmtlseek not stopped at a record boundary
tar: Error is not recoverable: exiting now

How do you use it? :slight_smile:

@Shamus: your download was incomplete. Hence “tar: Unexpected EOF in archive”

I had that problem too.
When I tried downloading with firefox it behaved like it was done, but the file wasn’t complete.
Downloaded again, using wget, and everything went fine.
Don’t know if this is an issue with firefox or if I just had bad luck first time i tried.

I have one hope, me to see that Czech translation file for Ardour from December 2010 in this location soon:


Hmm, in this day and age, we still have to deal with incomplete downloads… :frowning:

Maybe you could post the filesize and an MD5 sum next to the link so that these kinds of questions answer themselves in the future? :slight_smile:

I’ve been using Alpha3 for a day, imported tracks, and mixed using about 24 plugins and DSP was about 20% or below at all times, its been quite stable considering alpha condition, these are the bugs i’ve found so far (probably others have already)

Crash @

  • Moving multiple audio pieces (Once)
  • Adding audio from regions to tracks (Once)
  • Cleaning Playlist (unused audio data) - Once

Bug @

  • Font restored to 100% (twice after install)
  • LADSPA Plugin LAG or Malfunction (Noise Gate) - it doesnt seem to work at all
  • 1 Click touch on trim tool ocasionally (about 5 times now) trims all track but a little piece making it seem the whole track is gone

I’ll try to upload these bugs to the tracker but have no log becouse im such a noob in linux programming…

other than that, its a GREAT improvement over 2.8! very happy with it!

Thank Ardour developers for putting all that effort on this.

thanks for the email to ardour-dev on this, but as was requested, please don’t report bugs on the forums. it would be great if you could file these as bugs in mantis. you don’t need to be a programmer to report bugs.

Yes, i filed them under these numbers:

3910, 3909, 3906, 3912, 3913 and 3915 (this last one referes to the panning features not apearing in mixer but after several A3 reloadings.

For some of these i think A3a3 just needed to reboot but if that was intended the user would get a notification after install, or at least thats what i´ ve seen in other software.

Wow is all I can say right now. Ardour 3 seems to be a really huge step and I think I will have a lot to learn. The installer is genius and the interface looks, well, different, but it seems to be easy to get used to it.

I cannot wait to use it.

Hello devs,

Congrats for these alpha releases! They seem to work much better than the svn versions from a few months or even weeks back. I haven’t got the time to test thoroughly but this is already impressive!

Well, actually I was more interested to see how ardour3.0 would fare with VST support as I am using a drum VSTi that still requires wine. And I must say I am quite pleased with the direction it takes (could load the VSTi, tweak it, edit some notes in the MIDI track, playback, export, save, reopen the session and find everything as I saved them :slight_smile: ). Quick surface test but very promising so keep it coming :smiley:

Note to others: I compiled A3 from the svn source code. Don’t expect A3 alpha precompiled with VST support on this website or any other!!

Reading your post makes me ask - what “is” the scheduled Release date?

Great comment and my question is: What is the Release Date?

There is no currently scheduled release date, it will be released when it is deemed ready.


Thanks Seablade - I want to time my purchase of R3.0 with buying the new iMac and Mixbus…perhaps I should proceed with Mixbus and the iMac since I have the cash now and upgrade to R3.0 when its ready.