Ardour 2 b6.2 compilation error re: / FLAC

Compilation works fine for a while, then

libs/libsndfile/ undefined reference to FLAC__seekable_stream_encoder_set_seek_callback' libs/libsndfile/ undefined reference toFLAC__seekable_stream_encoder_process_interleaved’
libs/libsndfile/ undefined reference to FLAC__seekable_stream_encoder_get_resolved_state_string' libs/libsndfile/ undefined reference toFLAC__seekable_stream_encoder_set_write_callback’
… for a lot of lines

Compiling on ubuntu edgy with–I think–all the dev files I need, especially anything related to FLAC. Anyone know what’s going on?

I think I had somethig like this on fedora6.

Are there these lines in the config.log file in the arour2 build directory:

Checking for FLAC__stream_decoder_new() in C++ library FLAC... scons: `.sconf_temp/conftest_1.cpp' is up to date. scons: `.sconf_temp/conftest_1' is up to date. yes ?

I think the 1 in the name “conftest_1” might be some other number for you but that’s not important right now.

I had not installed the flac-devel rpm the first time I ran scons and it kept dieing late in the compile with errors very much like that even though everything including the flac-devel rpm was now installed.

I removed .sconf_temp/conftest_* and re-ran scons then all was fine.

I had problems building this box as fed6 hates it so I guessed it was just me and didn’t report it.
If this fixes things for you too then maybe you or I should raise it as a bug?

well, i deleted everything in .sconf_temp and tried again, and i got the same errors. then i just deleted the entire thing and re-unpackaged a new folder and it worked!

i don’t know exactly what “scons -c” does, but it doesn’t seem to clean everything

thanks a lot for the help.

Sounds close enough to be the same problem to me. I’ll try to re-create it and report it as a bug if I can.

The first run I did of scons was under my normal user account. I do that until I have a good build and then run scons install as root.

Can you recall if you first ran scons install as root or scons as a normal user ?

yeah- i ran ‘scons install’ as root, but built it via ‘scons’ as non-root. hopefully 7.1 fixed the cleaning problem, i haven’t bothered to check.

Remove libflac-dev and try again.

flac >=1.1.3 has changed its API, so compiling ardour (2.0.2) does not work when a recent version of flac is installed.

Here is a link to the flac porting guide:

saol adminim eywallah sikiş erotik video sikiş erotik video izleyin bakalım