Ardour 2.8 on Mac OS 10.5.7 (intel) does not play the music

I was trying to play a wav file on Mac OS 10.5.7 and it did not play. I had to export the wav file and played it in QuickTime. Has
any one encountered such a problem.?

I was using the 2.8 pre-built ardour executable. I also built the ardour executable but that also did not play the music.

Any thoughts…

You are the first person I know to report such behaviour. On the other hand, you’re not providing very much detail about what you actually did. There are many different reasons why a program like Ardour might not actually play audio.

I am also, frankly, amazed that you built ardour for OS X. How long did it take you?

I was trying to play a wav file on Mac OS 10.5.7 and it did not play. I had to export the wav file and played it in QuickTime. Has any one encountered such a problem.?

Not at all. So an imported file did not play in Ardour? Or an exported file from Ardour did not play in Quicktime?

If the former, what audio device are you using when you start Jack(Either when you start Ardour, or seperately using JackPilot or QJackCTL)? Are the meters on the track jumping? Are the meters on the master track jumping? What is your track and master track routed to?

If the latter what settings are you exporting the file with? Can you re-import into Ardour and play it there?



Here are the details that you wanted.

  1. I am using Mac Mini (Intel Processor) running Mac OS X 10.5.7.

    I built the executable and tried to play with the application. As part of that exercise, I tried to play a WAV file by importing it. Since
    I was not hearing the music, I thought there could be some problem with my build process. So I tried the same procedure on
    a pre-built executable and that also failed for me.

Hence I posted this message. I presume this could be some setting problem which I could not figure out.  I exported the tracks as
WAV file and played with Quicktime and I was able to listen to the music.

I did not face such a problem on a PPC. There also, I built Ardour from scratch. So I thought it was peculiar to Intel processor.

To build Ardour on OS X, it took approximately 10 hours. There were problems with the build script (python file). Had to fix them to
make a successful build on OS X. The documentation was helpful to get all the dependent libraries. But it was a tedious process.

Let me know if you need any further information.

Yes, the imported WAV file did not play in Ardour. I had to export it and played it Quicktime and was able to listen to music. The settings to export the file was Stereo, 16 bit, WAV, 44.1 KHz.

Used Jackpilot to start Jack. The meters were jumping but I could not hear the music.

maybe a jack issue ?
have you tried playing some audio through jack other than via ardour ?

If the meters on the Master track is moving, I’m guessing you haven’t connected the output from Master to the input of your soundcard.

Assuming JackPilot looks somewhat like QJackCtl you should have some ports on the right hand side of the Connections window that corresponds to your soundcard. Make sure Ardour’s master/out 1&2 ports are connected to them.
Another way of connecting is to click the Output button on the bottom of the Master track in the Mixer window and select Edit.


What interface are you using to play files? If using the built-in interface have you set up an aggregate device as required by 10.4 and newer courtesy of Apple?