Ardour 2.8.3 loses connection to JACK immediately

Hi All,

I’ve just built and installed Ardour 2.8.3 and I have a problem. As soon as I load any project (all of which were working on Ardour 2.8.0) Ardour displays the ‘JACK has been disconnected because it wasn’t fast enough’ (I’m paraphrasing, but I’m sure you know the one) message.

I’ll admit I’m running a very low latency setup (3 periods, 64 frames) but it’s always been very stable with earlier versions of ardour. I notice that the GUI looks quite different in 2.8.3 and wondered if perhaps this some graphics-intensive problem. I’m running an NVidia (yes, I know… :slight_smile: ) graphics card on a 2.6.31 kernel. Distro is Mandriva 2009.1

I’ve reverted back to 2.8 and it works as smoothly as it ever did.

Any guesses/help/greatly appreciated.


Nothing substantive has changed in the GUI between 2.8 and 2.8.3. I suggest you post screenshots of the “quite different” appearances between 2.8 and 2.8.3 on your system, since they might provide some insight into what might be causing the issues you are facing.

Thanks for the quick response Paul. On reflection I shouldn’t have used the word "“quite”, I think it has a slightly different meaning on this side of the Atlantic. I meant “it looks a bit different” :slight_smile:

Anyway here are some screenshots.

Ardour 2.8:
Session Control :
Editor :
Mixer :

Ardour 2.8.3:
Session Control :
Editor :
Mixer :

The difference I especially notice is the nasty black-and-white stripiness over the text.

Additionally, when creating these I noticed that one thing all my projects have in common is that they all use LinuxDSP effects, connected via inserts. So I found an old project which has only a couple of tracks and no inserts. This loaded fine but after playing it for a minute or so Ardour again lost connection to JACK.

Seeing as this might be graphics related I should note that I’m running this under KDE4. To check that it’s not due to some new version of a system library I have rebuilt Ardour 2.8 from scratch, and it still works fine.

Wow… thats all sorts of fun.

As long as you are not using SYSLIBS=1 (And you shouldn’t be) then system libraries shouldn’t come into play much here.

That being said, those are some interesting screen shots. That is definitely not what Ardour is supposed to look like(2.8.3). Do you have any output on your console/terminal when you run Ardour?


Ahhh… interesting…

(ardour-2.8.3:27977): Gtk-WARNING **: Unable to locate theme engine in module_path: “clearlooks”,

As I say I’m running this under KDE4, so I don’t have any GTK theme engines installed except the gtk-qt-engine. So I installed some GTK themes and the gtk theme engine and the GUI now looks exactly how I expect it to look. The JACK problem, however, remains.

Edit : As a test, I have removed the gtk-qt-engine. Apart from gtk apps now looking horrible ( :slight_smile: ) there is no change - ardour still disconnects from JACK as soon as I load a project. Maybe the GUI thing is a red herring?

Edit Edit : More experiments. I’ve increased my Frames/period in JACK from 64 to 512 (far too high for my purposes but just as an experiment). My session now loads and plays. However I notice something strange. When the transport is stopped, Ardour (and QJackCtl) are showing the DSP load as between 50 and 60%. This drops to 10% as soon as I start playback. This can’t be right. Under 2.8 the DSP load is always higher during playback, so what is Ardour now doing when the transport is idle?

Check your DeNormal settings. This sounds very much like it could be a denormal problem.


Thanks Seablade,

I tried a few settings. Enabling ‘Stop Plugins With Transport’ has fixed the 60% DSP usage when the transport is stopped. But I didn’t have to enable this in 2.8.

Using 512 frames in Jack, with these settings, I can get my biggest project to load and play all the way through about 50% of the time. But Ardour still loses connection with Jack if I try to save the project, or at random intervals during playback, and still won’t load a lot of the time.

Using my normal 64 frames I still can’t get the project to load without Ardour losing connection to Jack. With Ardour 2.8 I have no problems opening, playing, and saving this project with this frame size.

I’ve tried ‘DenormalsareZero’ and ‘FlushToZero’ but it has made no difference. It was previously set to ‘No processor handling’ (which is what it was set to in 2.8) ‘Use DC bias’ is off. My processor is a Core 2 Duo.

ardour include its own version of clearlooks. if it cannot find that, then there is something wrong with the build and/or the installation.

Thanks. Any suggestions as to what that problem might be? I built 2.8 from source and it works. I built 2.8.3 from source the same way and it doesn’t.

scons PREFIX=/usr
scons install

I ran the build again:

Checking for jack_set_thread_creator()…(cached) no

scons: warning: Ignoring missing SConscript ‘libs/clearlooks-older/SConscript’
File “/home/bob/src/ardour-2.8.3/SConstruct”, line 1408, in
scons: done reading SConscript files.

I’ll download the source again, maybe the gremlins got in.

Edit : Re-downloaded the source. Same problems. Ardour still can’t find clearlooks and still can’t open my projects.

I have /usr/lib/ardour2/engines/

that missing SConstruct file is a problem with the tarball. I’ll let you know when I can post a correction. apologies for that error.

OK thanks. This is getting stranger. I just installed Ardour 2.8.2 from a repository. This doesn’t have the clearlooks problem but it does still have the problem with losing connection to Jack. So it doesn’t look like my build is the cause of this.

Perhaps something on my system is making this happen, but what? 2.8.0 works perfectly. Is there a changelog I can look at to see if I can track something down?

[Post deleted because I was talking rubbish]

Thanks for your patience Paul. There’s definitely something strange going on here with my build.

I’m trying to compare the installation of 2.8 with the installation of 2.8.3.

So far I’ve found that in /usr/lib/ardour2, the 2.8.3 installation differs to the tune of 2 missing files:, and

I just read that the “broken” 2.8.2 package I installed earlier was built with SYSLIBS=yes, so I’ll discount that as showing me anything meaningful. I’ve checked mine, scons --help says SYSLIBS is FALSE.

we don’t use changelogs. svn diff can reveal all, but it will reveal hundreds or perhaps even thousands of lines of code changes.