Ardour 2.8.11 crashes while enabling record buttons...

After upgrading from Ardour 2.8.10 to Ardour 2.8.11 it crashes when track record button is enabled and one tries then to enable the record button in the transport section

Bug has been reported via MantisBT

Any solutions?


MacBook Pro 2.53 Ghz Intel Core i5
Mac OS X 10.6.3
Ardour 2.8.11
MIO Console 5
Metric Halo 2882 2d expanded

Possibly the following caused the problem:

It happend to an older session file, which I tried to configure as a homemade template without using the “save template” feature because I wanted a recorded click track and other things in it, which ardour templates won’t save… I did that by deleting all the audio in that old session file, renamed it and other such nasty things. After opening it again I was warned, that the “capturefiles couldn’t be initialized”. Of course I ignored the warning and tried to hit both the recording buttons-with the known result.
After building a template from scratch (rather than from an formerly existing old session file) the problem was solved.