Ardour 2.4.1 Tiger and libcurl.4?

Im trying Ardiour 2.4.1 and it tells me im missing libcurl.4 so wont launch. Im on 10.4.8 on a year old MBP and cant let the leopard in as i might get bitten. Is there a work around for us Tigers

LibCurl.3 is there and the ardour package actually looks at both when I looked inside ardour.

I also get a GlobPrefs and applecollation missing in the console but assume thats not a big deal

thanks in advance


PPC or Intel? native or X11?

Good timing - I tried the X11 version yesterday on my year old MBPro Intel 10.4.8 and got the libcurl4 error…
I just tried the native version and it works out of the box even through my digidesign 002 so maybe its an X11 problem - which I’d still like to fix
though with X11 attempt I did search in the referenced file “libardour.dylib” and found it referenced libcurl3+4 and I only have 3


For any mac users arriving here, the answer is to apply all apple system updates.

libcurl1.4.dylib is required, and should be present on your system if you have it absolutely up to date.

I applied all system updates, the lone one a few minutes ago being a Safari update.

There’s no libcurl1.4.dylib file on my system. Nor the earlier mentioned libcurl1.4

I searched and the only place I find it is on this site and a few stray other sites - but all having to do with Ardour.

So are these posts dated? Does the file actually exist? Is it used for ANYTHING else if it does?

I’m kinda baffled…

hmmm…I’m using 10.4.11 as we speak. Ardour works just fine…


You actually have to do one update AFTER 10.4.11 IIRC. It comes in in a mystery one afterwards, I don’t remember the actual name for it, but it definitely is in there when you have all the updates. You may need to download and manually apply the update from Apple’s site if your computer is not finding it, I posted how to do this at one point somewhere but would have to look through their site again to find it.


“You actually have to do one update AFTER 10.4.11 IIRC…”

I’m running 10.6.3


@silverface: this issue should not affect later versions of OS X. have you actually tried starting Ardour? if it didn’t work, post the Console log so we can see what is going on.


As Paul mentioned, libcurl should only ever be an issue on 10.4

If you are running into problems on 10.6.* you are likely running into other issues, or if it really is libcurl, something is very wrong with your system, we would need to see a console log and if applicable the crash report.