Ardoud export is unreadable by any other application

Hello, I’m a complete Ardour novice, but I sincerely tried to find the answer to question myself, still haven’t managed to find anything.

So my problem is that exporting session (or range) in Ardour goes excellent, and I can later import it into Ardour itself - the sound is there, everything is fine. But other applications (like vlc or audacity) refuse to open this exported audio files (complaining about unknown format and file being corrupted etc). I tried WAV, OGG, FLAC, both mono and stereo, both little and big endian, also I tried to export as a raw data - still no success.

Excuse me If my question is stupid or has been already already answered earlier, I really coudn’t find it around the internet and here.

BTW, I’m running Ubuntu 10.10, Ardour 2.8.11 from the repo, and I run it as a root user.

Thank you in advance for any help.

What are all the settings you are using, I would bet you are setting something up that other software isn’t flexible enough to read.


Thanks for anwering, Seablade!

Here are, for example, the settings I just tried to use and the file was not recognized by other programs:

channels: stereo
file type: WAV
sample format: 16 bit
sample endianness: little-endian (gray, cannot be changed for this format)
sample rate: 44.1kHz
conversion quality: best
dither type: none
cd marker type: none
in the list on the right “Audio1: out-1” is checked for the left channel and “Audio1: out-2” for the right one.

But as I said earlier, I tried to adjust each of these settings. Are there more settings beyond the Export window that I’m not aware of and can lead to such behavior?

A little off the original request topic, but as an aside, whenever you export to a fixed point format, you should enable dither, with triangular probability density function. Converting to a 16 bit format with dither not enabled is a non-linear process and results in high levels of distortion on low level audio. Not necessarily audible, but there is no reason to ever export to an integer format without enabling dither.

Regarding your original question, if you have the sndfile utilities installed (on my Fedora system provided by the libsndfile-utils package), run sndfile-info on the exported wave file, and include the output here.
Here is what I get from sndfile-info on an exported file which I was able to successfully convert to FLAC, Ogg/Vorbis, and MP3 formats:

Length : 11805360
RIFF : 11805352
fmt : 16
Format : 0x1 => WAVE_FORMAT_PCM
Channels : 2
Sample Rate : 44100
Block Align : 4
Bit Width : 16
Bytes/sec : 176400
data : 11805316

Sample Rate : 44100
Frames : 2951329
Channels : 2
Format : 0x00010002
Sections : 1
Seekable : TRUE
Duration : 00:01:06.924
Signal Max : 24461 (-2.54 dB)

– Chris C

“and I run it as a root user”

To expand on Xperienced’s point, the problem almost certainly is that the exported files are owned by root and not readable by your regular user. Or if it is readable, perhaps the programs you are trying to use with it (like audacity, which is an editor) are trying to open it read/write and it is not writable. Do a chmod on the exported files (and on all the files in your project directory, so you can work on them in the future) and you will most likely be able to open them.

The real solution is to stop running ardour as root. Make sure your limits.conf is set up correctly, add yourself to the audio group (or whatever is specified in limits.conf), log out and log in again, then start jack and ardour as your regular user from now on.