Ardoud 2.8.2 vs Snow Leopard

Hello all,

I have installed Snow Leopard a few days ago and since, Ardour doesn’t read. I can launch Ardour, launch LADSPA and AU plugins everything seems to be ok but the transport does not work anymore.

Am I the only one since I can’t find any topic on this subject on any forum.

Best regards,

Thanks for answer.

I’ ve just recovered my Motu Ultralite from a friend and launched Ardour successfully, so, Jack was the “problem”.


I was running Ardour 2.8.1 with JackOSX 0.82 under the base Snow Leopard successfully for about a week. Occasionally I would get messages that Jack had disconnected Ardour and had to restart it, but that was after running other applications with Ardour and Jack in the background. I’m not sure I ever tried using the transport though, usually I’m just using it as a mixer. Then today for some reason Ardour decided it wouldn’t start anymore. It would give me the dialog to choose a session to open and then after choosing one I’d get the ‘application terminated unexpectedly’ message. It doesn’t matter if I have the Jack router started or not. Apparently it never gets far enough to check. Usually when something like this happens I suspect a corrupted preferences file and remove it, but Ardour doesn’t seem to have one that I can find. The only other thing I can think of is an issue with a plugin, although Garageband starts up ok.

After it started failing I updated to Ardour 2.8.2 and OS 10.6.1 (iTunes was also updated). The behavior is exactly the same. I can choose a session to open and then it dies. Any guesses at things to check and/or remove?

Can you create a new session? Is there any output on the console?

It sounds like you have a corrupted session file in some fashion.


No. It dies whether I try to open any of several sessions or create a new one. I also tried creating a session in my administrator account rather than my user account. It gives the the screen that says “Starting Audio Engine” along with the spinning beachball, and then it dies. I guess I could try downloading with Firefox instead of Safari and reinstalling just in case it was corrupted somehow. That wouldn’t explain why it stopped working before I updated it though. I also tried moving the .ardour2 directory using the terminal so it would have to regenerate the hidden preferences. Still dies.

This is the start of the crash report, I won’t paste the whole thing:

Exception Codes: KERN_INVALID_ADDRESS at 0x000000008e594900
Crashed Thread: 0 Dispatch queue:

Thread 0 Crashed: Dispatch queue:
0 libfontconfig.1.dylib 0x1ecdea85 FcStrListCreate + 51 (fcstr.c:1091)
1 libfontconfig.1.dylib 0x1ecd708a FcLangSetHasLang + 193 (fclang.c:388)
2 libfontconfig.1.dylib 0x1ecd8bfa FcCompareLang + 139 (fcmatch.c:104)
3 libfontconfig.1.dylib 0x1ecd8f30 FcCompareValueList + 401 (fcmatch.c:325)
4 libfontconfig.1.dylib 0x1ecd925c FcCompare + 202 (fcmatch.c:404)
5 libfontconfig.1.dylib 0x1ecd99f6 FcFontSetSort + 345 (fcmatch.c:708)
6 libfontconfig.1.dylib 0x1ecd9f34 FcFontSort + 89 (fcmatch.c:837)

And here are the last couple of lines from the console:
9/16/09 9:17:54 PM [0x0-0x10010].org.ardour.Ardour2[165] JACK server starting in realtime mode with priority 609/16/09 9:18:09 PM[110] ([0x0-0x10010].org.ardour.Ardour2[165]) Job appears to have crashed: Segmentation fault

I tried reinstalling JackOSX just in case the system updates had stepped on something, but it made no difference.

I tried downloading with Firefox and reinstalling, but it didn’t help. If the the references to libfontconfig in the crash report are meaningful, I wonder if it could have anything to do with this. Apparently Apple changed the way some fonts are handled in Snow Leopard and eliminated one font type. I remember reading about this issue in the Inkscape forums. Could it be that the old fonts were somehow cached even though I upgraded the system and when the cache was eventually cleared or updated it stopped working?

Well first things first…

rm -rf ~/.fontconfig/

See if that makes a difference for you.

Otherwise would need a lot more info from those. Make a Mantis issue for this and attach the crash report there and the console log. Make certain you specify the version of Ardour and OS X in it.


Thanks. That fixed it. I’ll bet it was Inkscape that broke it. I started using that heavily in the last few days. I guess the font system is a bit less than robust.

I’m not sure what isn’t supposed to work on 10.6 now, unless 10.6.1 fixed whatever it was. Ardour works as a mixer and I can also play back previously recorded material and make and play back new recordings. I haven’t tested it extensively of course, just a few quick checks.

We received initial reports of Ardour working on Snow Leopard, and indeed Ardour seems to work fine. The problem is that Jack seems to be hitting an issue or two, and as such I can’t get playback at all using the currently available JackOSX packages. I believe the Jack crew is aware of this and working on it currently, but until things get released I wouldn’t hold your breath at this point. I haven’t tried compiling Jack from SVN as of yet, I just haven’t had time to set up my normal dev environment on OS X yet since i upgraded, but will try to do so this week I suppose and see if I can get any farther.

In the meantime I haven’t found any Jack applications that work on OS X as a result of this, with the JackOSX packages of course.


@seablade: I have sort of the problem that you describe. Ardour tells me Audio Setup value for outputdevice is missing data.

Do you know how to fix this? Or is there somebody working on fixing it for SnowLeopard. I am already regreting, that I’ve updated to SnowLeopard. But otherwise that’s just how it is with new systems.

I’d be greatful for a solution.


There are beta’s of JackOSX that address a lot of the problems, but until they finish working on it(And they are in fact working on it) it won’t quite provide the same experience. However that being said, feel free to try one out, I think you should be able to find it via Google. But understand that we can’t support anything on Snow Leopard until an official release of JackOSX comes out that fully supports it.


Thanks Seablade. Do you think that this a matter of weeks or a matter of months? I know it’s an unnecessary question and you probably can’t answer that. It’s just that I can’t wait for going on using Ardour. One more thing… There’s no alternative Audio Server you might know? I mean for meanwhile… Anyway. Thanks for your quick response.


Alternative Audio Server that works with Ardour? No.

How long do I think it will be, complete guess but I would say weeks is MUCH more likely than months.


I was looking for some Beta Version of JACK for OSX but I havent found one. Nowhere. So maybe I am to stupid finding it or there is none. I need some help from SEABLADE or someone else. But I know SEABLADE is kind of “the man” around here. Could someone send me a link or something?

That would be very helpful.


If you cannot find it with google, that strongly indicates that you probably should not be using the JackOSX beta release at this time. Please wait until it is released.

OK Paul. I’ll wait. Could you just give me some clue, how long that 'll be. I’ve just discovered Ardour, and it’s really easy to (means I am not too dumb for it, which is a rare situation ;-))) use and I really like to continue finding stuff out and experimenting. I don’t wanna be a nag… but I guess I am asking this useless questions.

Anyway… you RULE for creating Ardour Paul. Thank you for doing this.

Greets from Vienna

From the Jack OS X site:
“Version 0.83 now available, including Snow Leopard support!”
So, I guess this means Ardour should now behave correctly on 10.6.1.
Also, they should now be testing a 10.6.1 release of Mixbus at this very moment, right?!?

It does work fine. Although when I start Ardour i gives me this Errors. Do I need to adjust something or is that normal. I didn’t get these Errormessages before.

[ERROR]: No devices found for driver “NetJACK”
[ERROR]: AudioSetup value for interface is missing data
[ERROR]: AudioSetup value for inputdevice is missing data
[ERROR]: AudioSetup value for outputdevice is missing data

Maybe someone?

You are starting Jack with the NetJack Driver, you need to make sure this is set to CoreAudio, NOT Netjack.


Please Post SL Reports.