An Ubuntu studio problem (sorry if not allowed in here)

Hi folks this is an adjacent one so sorry if it’s not allowed. If this isn’t the right place for this I’d really appreciate it if someone would point me to the best place to ask.

I’ve just installed Ubuntu studio on a new machine and when using my external sound interface I’m getting serious distortion / ring modulation. I’ve tried both the latest lts and the latest release in both live mode and when installed. I don’t have the issue in windows with the same interface.

On Linux the issue happens when watching media content and when Jack’s running too. I’ve tried multiple sample rates whne using jack and I’ve also tried forcing pulse audio to 48000 using this Bug #1966066 “audio from external sound card is distorted” : Bugs : linux-signed-hwe-5.13 package : Ubuntu advice.

Any help would be greatly appreciated.

Many thanks



It appears the answer is in the bug report you linked, they have links there to kernels that have had this USB regression fixed, you should be able to install them and if it’s the same issue as reported the issue should disappear.

Thanks so much for your reply. I had seen that and I have to confess I was hoping someone could provide an alternative solution. You see I am that most fabled of creatures - the completely non-technical desktop linux user who would be a windows in that they just want to switch it on and it all be fine but without wanting to be a windows user. I’ve never updated a kernel before and I fear it’s beyond me. Having said that this new box has never been used so if I totally bork it there’s nothing on there precious - I still have my machine that I’ve been using so far so I’d better clear some time in the diary and give it a go. Wish me luck. Thanks again.

Probably the easiest non-technical solution if you want to do AV production on Linux? Try AVLinux instead:)

1 Like

Hi again,

I understand your apprehension, I would hope that if this is a known issue with that release of Ubuntu Studio that it would be addressed in a Kernel update through the Package Manager and simply running an update would fix it…?. What version of Ubuntu Studio is it that you have installed? 5.13 seems like quite an old Kernel… Can any other Ubuntu Studio users here comment?

  • UbuntuStudio 20.04 (focal) was running a 5.4 kernel when I last updated it (six months or more ago).
  • UbuntuStudio 22.04 (jammy) runs either a 5.15 kernel or a 5.17 kernel, depending on the hardware (from the release notes for Jammy).

Curiouser and curiouser. I’ve tried the same distro (live booting from the same USB stick) on my laptop and I’m not getting the same issue - the same interface is working perfectly. I’ve also now tried avlinux in live mode on the offending box and I’m getting the same issue. I no this is one of those infuriating posts that basically says ‘help I don’t know what I’m doing please fix it for me’ but that’s not really what I mean - I’m not asking for anyone to spend any time on this - especially because I have a perfectly working set up already on my laptop (I’m just gready and wanted the upgrade) but if anyone has any ideas how I might proceed I’d greatly appreciate it.

And also many thanks for the responses that you’ve given everyone - I do really appreciate the time you’ve taken to look at this.



This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.