[am I stupid ?] can't import audio in Ardour

i’m using ardour 2.8.11/7387
on mac osx 10.6.6
and experiencing the most stupid problem : i just can’t import any audio file at all.

If i try through the menu file>import, i can select files, preview listen to them, have any kind of information about them, but can’t import, i click “apply” or “ok” and it comes back to the ardour interface with no change at all, and the console log does not display any error, and if i try to drag an audio file in ardour, there’s a new track created but no audio files, neither error message.
At first i realised that ardour did simply ignore audio files without an extension in their name, which is a little problematic on osx. So i gave extensions for my audio files, but nothing, i.e. they were found by ardour but never imported. I tried several sampling rate and again nothing.
I think i’m missing something obvious here… but i don’t see what.


Try to catch me this afternoon EST. It will be much easier to track down on IRC where communication is realtime, rather than over the forums.

Using the exact same setup without problems I can tell you it is certainly something particular with your system.


so… after some time full of suspense and action, the problem seems identified and solved. It’s merely a jack osx related problem, and a relaunching of jackpilot (after disconnecting jack) seems to solve the problem.

When the problem happens, jack does spam the console in this way : http://pastebin.com/SbEZJe9Z
and after that i had some trouble configuring outputs in a good way, i wonder if the auto connect to physical outputs / master bus does work well.

anyway now all seems fine ! lot of thanks again Seablade :slight_smile: