ALSA not an option when creating a session

OS: Fedora Workstation

It’s not well-illustrated in this pic, but the drop-down for JACK only gives me the option to use JACK. I’m not sure I want to go through with setting up JACK – It’s not completely necessary to me now.

ALSA worked fine on LMMS; not sure what’s happening. I feel like I’m bringing up an issue that’s been solved or could be solved. I apologize if that’s the case, I’m kinda impatient now.

Where did you get Ardour from? Is this a Fedora package, or perhaps a self-built version?
Most likely perhaps the ALSA backend was not enabled at compile time (or perhaps packaged separately).

Check Ardour menu > Help > About > Config … scroll down and see if

ALSA Backend: True
1 Like

If jackd is running does Ardour still give you the option to choose the ALSA backend?
If this is running on Fedora then the backends are packaged separately, for ALSA you need to install package ardour5-audiobackend-alsa

Depends. Ardour asks, unless (1) you have used Ardour/JACK the most recent time Ardour was started and (2) jackd is running.

Is this the case again?

We asked Fedora packagers to not do this anymore and for a time there was a monolithic package for all of Ardour. Besides, Ardour/ALSA is the default, if at all JACK should be optional.

This is on the latest Fedora 31:
$ rpm -qa | grep ardour
ardour5-audiobackend-alsa-5.12.0-14.fc31.x86_64
ardour5-audiobackend-dummy-5.12.0-14.fc31.x86_64
ardour5-5.12.0-14.fc31.x86_64
ardour5-audiobackend-jack-5.12.0-14.fc31.x86_64

I have had the packages installed so long I don’t know if the ardour5 package will force pulling in all backend packages or not.
Looks like the ardour5 package will accept any backend package as filling the dependency:

$ dnf deplist ardour5
package: ardour5-5.12.0-14.fc31.x86_64

dependency: ardour5-audiobackend(x86-64) = 5.12.0-14.fc31
provider: ardour5-audiobackend-alsa-5.12.0-14.fc31.x86_64
provider: ardour5-audiobackend-dummy-5.12.0-14.fc31.x86_64
provider: ardour5-audiobackend-jack-5.12.0-14.fc31.x86_64

Fedora package…

Thanks, that fixed it. I really ought to learn how to use jackd in the future. If I read more I prob could’ve solved this.

Well this was the case. I had to install the backend. Annoying bc I wasn’t sure how to get Ardour running otb. I struggled with this before, but didn’t try to do anything about it till I actually needed to get work done.

Why? You only need JACK if you want to route audio between applications (or share the soundcard with other JACK apps).

The latter. Except I’m back to lmms again bc I’m used to it.

Hi Robin,

How does one enable ‘ALSA Backend’ while building Ardour ?

Thanks
Regards

./waf configure --with-backends=jack,alsa,dummy ...
I suggest to compare to https://nightly.ardour.org/i/A_Linux_x86_64-gcc5abi/build_log.txt

2 Likes