All of the LV2 vibe plugins are broken. Underlying issue?

So I know Ardour core development has nothing to do with plugins… however all of the available vibe plugins (from different creators) have issues, which makes me wonder if there’s not some common thread.

In the guitarix package, GxVibroChump (an amp with a vibe block), GxVibe and GxVibe mono all work… until you reload Ardour. Then they kill the signal chain (mute or near-mute) at the point of the plugin when the vibe is in the “on” position. When off, the signal gets through fine.

rkrVibe (rakarrack) does the same thing when you first add it to the track. Mute or near mute. When you bypass, the sound gets through (obviously) but sound also comes through when you UNbypass. In other words if you “jiggle it” you can get audio to come through when it is enabled. BUT still no vibe. None of the parameters seem to have any effect. Well “pan” seems to, but nothing else.

Related(?), but different, GxTubeVibrato works (I guess) but the effect is very subtle and the depth/speed knobs do basically nothing, as far as I can tell.

Anyway, just wondering if these vibe-related issues are (a) caused by some problem underlying how vibes work in LV2 and/or (b) isolated to my particular PC configuration somehow?

Ardour6, guitarix 0.38.1, rkr LV2 ports from

Try (vibefix branch) perhaps

See also

I really appreciate this. rkrVibe works for me now, although it did segfault when I first added it, maybe due to the old version having been there before. And there were a couple of times I got a continuous loud screech from it, but I wasn’t able to reproduce.

In any case, I think this does what I need. :+1: For extra effort.

edit: What was the issue?

The main issue was due to uninitialized variables in the filter-stage. When loading the plugin some random numbers were used. In some cases the filter could settle down, or were [near] zero.

I think I spoke too soon. When I close the session, open it back up, move my playhead to a spot where the vibe should be active, it mutes the track (at the point of the plugin).

I’m pretty sure I installed your new version correctly, but is there a way to check without recompiling?

Does the dry/wet control work?

In the rkrlv2 git repo, does git log -n 1 say f0b67bea7ce4584590f3eb691ce6b6ba5f94aad7 ?

Maybe you have installed rkr twice in different locations. When you start ardour from the commandline, are there any warnings about duplicate plugins lilv_world_load_bundle(): ... messages?

PS. It may well be that I’ve missed some issues, but in some quick tests the patched rkrVibe works reliably here.

Yes that string matches.

It seems to be working again now. I can’t reproduce the “mute” issue.

One of the confusing things is that the “depth” parameter is bizarre. The higher you go, the less intensity/depth there is. Anything above like 40 doesn’t sound vibey at all. I had to use one of the presets to figure that out.

Anyway, I’ll keep you posted and thanks again.

thanks for testing the rkrlv2 plugins. Unfortunately after I ported them over I never have had time to do a proper thorough testing of all 42 plugins. I was hoping the community would be able to provide more effort on that front. I’ll see if I can check out the depth. Its possible I messed up the control for it. If you are able to check the standalone rakarrack app and compare behavior there that will really be the smoking gun. If you can’t then I’ll just compare the code and see if I messed something up in translation.

Ok, I looked into the depth thing and agree it’s weird, but its the same as the original sounded, so I’m committed to keep the sound the same. In the unrealistic scenario that I get the time to totally re-do the DSP code for all these, I’ll probably fix that for rkrv2.

Thanks for starting this conversation, its forced a little progress into the code which sadly hasn’t happened for a long time. Props to Robin for the patches and insights too, Thanks.

@ssj71 At one point I was considering making an effects plugin based on the Rakarrack code, without particularly trying to be backward compatible. I can’t make any promises about when I could do it, but would you be interested in collaborating on such a project?

certainly. falktx actually expressed a similar interest a few years ago and I started a github organization for it. It never went anywhere, but I’ve invited you to it. I’d love to see some progress in that direction.

Nice. I’ll stop dragging this out on a tangent, but I’ll note that the org hasn’t had any activity since 2015! I think that’s the year that I got back into the music hobby and started learning how to use Ardour :rofl: