All exports from Ardour are unplayable! :(

I had a relatively simple project to work on tonight, so I decided to give it a try in Ardour. Everything seemed ok, and I was happy with the way the project sounded, when I got to exporting it.

So far I’ve tried literally every export format that Ardour supposed and they all do the same thing (well, all except flac-- for that I get an error saying it doesn’t actually know that format): the file is created and has data, but if I try to play it in Totem (which I’ve confirmed works for other files) it gets a track length, but any attempt to play it just does… nothing. It doesn’t even advance through the track. If I import into Audacity it can read the waveform fine, but again any attempt to play it just causes Audacity to sit there. I even tried importing into Audacity and then exporting from there as an mp3 and the problem persists.

I’m running Ardour 2.8.6 on a fully updated Ubuntu 10.04 Lucid. I’ve search around for answers but, while I have seen some references to the problem, particularly with .wav exports, I haven’t found a solution. I would really hate to lose all the work I’ve done because I can’t get my project out of Ardour. Halp!

In another thread about .wav problems someone requested that the poster include the output of sndfile-info on the file. That thread never went anywhere, but here’s the output in case it’s helpful:

Version : libsndfile-1.0.21

File : SamMcGee-produced.wav
Length : 174894284
RIFF : 174894276
fmt : 16
Format : 0x1 => WAVE_FORMAT_PCM
Channels : 2
Sample Rate : 48000
Block Align : 8
Bit Width : 32
Bytes/sec : 384000
data : 174894240

Sample Rate : 48000
Frames : 21861780
Channels : 2
Format : 0x00010004
Sections : 1
Seekable : TRUE
Duration : 00:07:35.454
Signal Max : 2.14748e+09 (0.00 dB)

Another thing possibly worth noting: sndfile-play can’t play the file either.

Well a couple of things… One is Ardour or Jack still running when you try to play this? Jack will take complete control of your audio interface and nothing else can use it, so you will need to use a Jack enabled player (Aqualung is a good one) in order to audition without killing Jack.

Two. You are using an Ubuntu Package, and they tend to have problems. Not only this but it is a rather old package as there have probably literally been hundreds of fixes since then. I would suggest trying the binary from this site.

But I suspect your problem is actually issue number one.


Huh… I was sure that Jack wasn’t running, and I even managed to play another media file in the same app. And yet, I come back this morning, and all the files play. O.o

So… thanks.

One other possible explanation: Was QJackCtl still running when you were unable to play the file? On my 10.04 systems, /usr/bin/qjackctl is a shell script that launches the QJackCtl binary using pasuspender — so PulseAudio is suspended until you quit QJackCtl, and any apps that try to use PA will be silent.

This has tripped me up a few times.


Recently I have been finding that Qjackctl doesn’t close jackd properly when it is exited so you have to manually kill it from the system monitor, that might have been the case.


QJackCTL typically on purpose doesn’t kill Jack when exited, only when you hit STOP. in QJackCTL.

I will also say i have had some strange behavior from jackdbus when I was trying to use Jackd to start and stop Jack. Until I figured out I needed to set QJackCTL to use jackdbus I would have difficulty stopping Jack properly.


@seablade: Ah ok thanks, this behaviour wasn’t obvious to me.